No Network Using Qemu-kvm-ev-2.3.0-31.el7.16.1

Home » CentOS-Virt » No Network Using Qemu-kvm-ev-2.3.0-31.el7.16.1
CentOS-Virt 5 Comments

Hi all,

To do some tests, I have installed a new CentOS7 host (fully patched) using qemu-kvm-ev-2.3.0-31.el7.16.1 instead of qemu-kvm’s default package. And I have problems with network inside my guests.

All guests can ping to CentOS host but nothing more: can’t resolv dns names, can access via tcp to other hosts, etc … Using same config on other CentOS7 host, but using default qemu-kvm package instead of qemu-kvm-ev-2.3.0-31.el7.16.1, all works ok.

What am I doing wrong? Or is it a bug?

Thanks

5 thoughts on - No Network Using Qemu-kvm-ev-2.3.0-31.el7.16.1

  • Ok, problem is not with qemu-kvm-ev-2.3.0-31.el7.16.1 package, it is with systemd-networkd. I have installed openvswitch and all works ok. Then, my question, is why is it not possible to use systemd-networkd for configure virtual switches to use them with KVM guests in CentOS 7 (using for other things, they seem work ok)??

    In Ubuntu, Arch and Debian there is no problem with systemd-networkd configured bridges for KVM guests.

    Any idea why ??

    Thanks.

  • Martinez, Any more config you have checked for DNS resolution related? You can ping to other host in the network right?

    Xlord

    —–Original Message—

  • Hello, this could be issue with firewall or netfilter on bridge

    S pozdravem Kristián Feldsam Tel.: +420 773 303 353
    E-mail.: admin@feldhost.cz

    http://www.feldhost.cz – FeldHost poskytuje kvalitní hostingové a serverové služby za příznivou cenu.

    FELDSAM s.r.o. V rohu 434/3
    Praha 4 – Libuš, PSČ 142 00
    IČ: 290 60 958, DIČ: CZ290 60 958
    C 200350 vedená u Městského soudu v Praze

    Banka: Fio banka a.s.
    Číslo účtu: 2400330446/2010
    BIC: FIOBCZPPXX
    IBAN: CZ82 2010 0000 0024 0033 0446

  • Nop. Problem was with systemd-networkd. Using openvswitch of ifcfg-XXX config files, all works ok without problems.


    Greetings, C. L. Martinez

LEAVE A COMMENT