Xen 4.4.2 (with XSA-132) In Virt6-testing

Home » CentOS-Virt » Xen 4.4.2 (with XSA-132) In Virt6-testing
CentOS-Virt 6 Comments

I’ve got Xen 4.4.2 in virt6-testing. I haven’t had a chance to test it, and won’t for another week or two; but if some volunteers can put it through its paces, I can ask Johnny to push it to the public repo sometome early next week.

Thanks,
-George

6 thoughts on - Xen 4.4.2 (with XSA-132) In Virt6-testing

  • I’ve upgraded to Xen 4.4.2 and everything went fine. I’ve tested save/restore and few basic stuff, all good.

    [root@dev1 ~]# uname -r && xl info|grep xen_version
    4.0.1-1.el6.elrepo.x86_64
    xen_version : 4.4.2-1.el6
    [root@dev1 ~]#

    Note; I’m using kernel-ml from elrepo because x4c kernel is too old LTS for me.

    Karl

  • WRT a new kernel .. the 3.18.x kernel has been selected to be maintained as an LTS until Jan 2017. I think we should start work on rebuilding this kernel and using it in the x4c projects.

    https://lwn.net/Articles/636289/

    Thoughts?

    I will grab this kernel and try to roll in all the patches, etc. and see if I can make it work.

    Thanks, Johnny Hughes

  • Karl,

    Note: We use a non released version of blktap (version 2.5) from the xen maintainers .. I don’t think the blktap (if it even exists) in the main line kernels will work properly. But, I could be wrong .. George or Lars, what do you think.

    There are other devices that can be used, so obviously that kernel can still work, since you are using it now :)

    Thanks, Johnny Hughes

  • Unless there are any objections, I’ll ask for this to be pushed tomorrow (Wednesday).

    -George

  • I just finished my testing of Xen 4.4.2 rpms, and they seem to work OK for me!

    Thanks,

    — Pasi

LEAVE A COMMENT