Can Someone Help Confirm A Bug? Kio_http Kdegraphics

Home » CentOS » Can Someone Help Confirm A Bug? Kio_http Kdegraphics
CentOS 4 Comments

Hello:
I’m trying to track down a kio_http problem using CentOS 6.4 with KDE. This causes multiple kio_http procs to spawn and lots of notifications.

Several steps are needed:
Create a foo.html with an href foo.html
Testhttp://ovh.com [^]

Use html2ps then ps2pdf to create a PDF document

html2ps foo.html>foo.ps ps2pdf foo.ps okular foo.pdf

Using the KDE desktop, open the PDF in Okular then click the click. Immediately there are desktop notifications that website was contacted and waiting for reply. A ‘ps -ef’ shows man kio_http processes being spawned.

I’m not able to reproduce on all random websites, but the ovh.com always does so. This link was found in the latest Linux Journal so others may inadvertently cause this.

4 thoughts on - Can Someone Help Confirm A Bug? Kio_http Kdegraphics

  • Hello Kwan,

    I will fire up a KVM vm and try to reproduce the problem/bug with the steps provided, in what architect are you currently experiencing this with?

  • Thanks Earl…

    I am running on CentOS 6.4 64bit (x86_64). I’m spinning up a RHEL
    instance to see if it’s an upstream issue also.

  • Kwan,

    I carried out the steps using the following

    Build: CentOS 6.4 x86_64
    Kernel: 2.6.32-358.11.1.el6.x86_64

    I only installed html2ps, everything else was installed using the default Desktop installation together with the KDE GUI.

    When I click on the “click,” which point to http://ovh.com, I receive two notification and the same behaviour as you mentioned previously.

    When I check the output of “ps -ef,” I see the following, this was for two windows though.

    kde 5136 2352 1 13:09 ? 00:00:01 konqueror -mimetype text/html http://ovh.com/
    kde 5140 2352 0 13:09 ? 00:00:00 kdeinit4: kio_http
    [kdeinit] http local:/tmp/ksocket-kde/klauncherMT2353.sla kde 5142 2352 0 13:09 ? 00:00:00 kdeinit4: kio_http
    [kdeinit] http local:/tmp/ksocket-kde/klauncherMT2353.sla kde 5143 2352 0 13:09 ? 00:00:00 kdeinit4: kio_http
    [kdeinit] http local:/tmp/ksocket-kde/klauncherMT2353.sla kde 5155 2352 2 13:10 ? 00:00:01 konqueror -mimetype text/html http://ovh.com/
    kde 5159 2352 0 13:10 ? 00:00:00 kdeinit4: kio_http
    [kdeinit] http local:/tmp/ksocket-kde/klauncherMT2353.sla kde 5161 2352 0 13:10 ? 00:00:00 kdeinit4: kio_http
    [kdeinit] http local:/tmp/ksocket-kde/klauncherMT2353.sla kde 5162 2352 0 13:10 ? 00:00:00 kdeinit4: kio_http
    [kdeinit] http local:/tmp/ksocket-kde/klauncherMT2353.sla kde 5164 2352 0 13:10 ? 00:00:00 kdeinit4: kio_file
    [kdeinit] file local:/tmp/ksocket-kde/klauncherMT2353.sla

    I also get the same results from SL 6.4 x86_64, hope this helps.

LEAVE A COMMENT