Can’t Install Gcc

Home » CentOS » Can’t Install Gcc
CentOS 1 Comment

Hi, I’m having this odd problem with being unable to install gcc, this is what I tried and what I’m getting as an error:

$ sudo yum install gcc.x86_64
Loaded plugins: security Setting up Install Process Resolving Dependencies
–> Running transaction check
—> Package gcc.x86_64 0:4.4.6-4.el6 will be installed
–> Processing Dependency: cpp = 4.4.6-4.el6 for package:
gcc-4.4.6-4.el6.x86_64
–> Processing Dependency: glibc-devel >= 2.2.90-12 for package:
gcc-4.4.6-4.el6.x86_64
–> Processing Dependency: cloog-ppl >= 0.15 for package:
gcc-4.4.6-4.el6.x86_64
–> Running transaction check
—> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed
–> Processing Dependency: libppl_c.so.2()(64bit) for package:
cloog-ppl-0.15.7-1.2.el6.x86_64
–> Processing Dependency: libppl.so.7()(64bit) for package:
cloog-ppl-0.15.7-1.2.el6.x86_64
—> Package cpp.x86_64 0:4.4.6-4.el6 will be installed
–> Processing Dependency: libmpfr.so.1()(64bit) for package:
cpp-4.4.6-4.el6.x86_64
—> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.7 will be installed
–> Processing Dependency: glibc-headers = 2.12-1.80.el6_3.7 for package:
glibc-devel-2.12-1.80.el6_3.7.x86_64
–> Processing Dependency: glibc-headers for package:
glibc-devel-2.12-1.80.el6_3.7.x86_64
–> Running transaction check
—> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.7 will be installed
–> Processing Dependency: kernel-headers >= 2.2.1 for package:
glibc-headers-2.12-1.80.el6_3.7.x86_64
–> Processing Dependency: kernel-headers for package:
glibc-headers-2.12-1.80.el6_3.7.x86_64
—> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed
—> Package ppl.x86_64 0:0.10.2-11.el6 will be installed
–> Finished Dependency Resolution Error: Package: glibc-headers-2.12-1.80.el6_3.7.x86_64 (updates)
Requires: kernel-headers Error: Package: glibc-headers-2.12-1.80.el6_3.7.x86_64 (updates)
Requires: kernel-headers >= 2.2.1
You could try using –skip-broken to work around the problem You could try running: rpm -Va –nofiles –nodigest

I tried this workaround, but with no avail:
http://www.CentOS.org/modules/newbb/viewtopic.php?topic_id9018&forumV

Downgrading did not work.

The only repo that I’ve enabled is epel.

What am I missing or not doing correctly?

One thought on - Can’t Install Gcc

LEAVE A COMMENT