CentOS 7.3 And E1000e

Home » CentOS » CentOS 7.3 And E1000e
CentOS 8 Comments

Hi All – I have a box running the above. Power was lost long enough that UPS did not work. When power came back on the C7 box boots way faster than the switch and resulted in no network. power cycling the C7 box resulted in network.

This even happened a second time. The only way to get the box back was to power cycle. the box is remote and no keyboard and mouse connected.

Any thoughts on why the e1000e would not talk to the switch ? The switch is an unmanaged linksys – could not get the model. It auto negotiates to
1G/full.

Thanks, for any thoughts.

Jerry

8 thoughts on - CentOS 7.3 And E1000e

  • an unmanaged switch should be live within milliseconds of power being applied, it doesn’t make sense that an OS could boot up before its working.

  • /usr/share/doc/initscripts-9.49.37/sysconfig.txt

    /etc/sysconfig/network-scripts/ifcfg- and

    LINKDELAY=

    Tru

  • Had you used NetworkManager, it would have detected the network coming up and started networking. This is one of the reasons why I continue to use NM for our servers, I’ve been in similar situations (where power is restored to the rack with computers in it before to the rack with the networking equipment). The ‘network’ sysv service just runs once and gives up if it can’t bring up the network.

    The problem with LINKDELAY= is that it will always slow down the network service (even if the network is fine), and if you set it too high, might cause other services which rely on it to time out.


    Jonathan Billings

  • This may be the wrong approach, but install the NetworkManager-config-server rpm. It sets a config option to allow interfaces to be configured before being available, which may help.

  • At 07/07/2017 at 22:00, Shakespearean monkeys danced on Jerry Geis’s keyboard and said:

    +1 on the switch not being completely up itself.

    You could also stick in a (longer) pause at the boot screen.

    Cheers!

  • What I did on couple of my CentOS boxes is:
    – use a bridge which is connected to the specific nic(will always look as up after boot)
    – Run a cron script that checks if the nic state is “NO-CARRIER” or other weird situations like no IP address and try to run ifdown X-nic and then ifup X-nic.

    Depends on the hardware and situation you might need to choose what fits youe environment as a solution instead of fixing the whole CentOS distro.

    All The Bests, Eliezer

LEAVE A COMMENT