CentOS6.8 And Python33

Home » CentOS » CentOS6.8 And Python33
CentOS 3 Comments

I’ve some trouble with installing numpy in python 3.3 on CentOS 6.8 as installation request a different python version…

[root@sge ~]$ yum install python33 python33-python-tools
[root@sge ~]$ scl enable python33 bash
===== *this load Python 3.3.2* ==[root@sge ~]$ easy_install pip
[root@sge ~]$ pip install numpy Collecting numpy
Using cached numpy-1.12.0.zip
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File ““, line 1, in
File “/tmp/pip-build-wyb0pj/numpy/setup.py”, line 34, in
raise RuntimeError(“Python version 2.7 or >= 3.4 required.”)
*RuntimeError: Python version 2.7 or >= 3.4 required.

[root@sge ~]$which python
/opt/rh/python33/root/usr/bin/python
[root@sge ~]$which pip
/opt/rh/python33/root/usr/bin/pip

*I’m not familar with python and I do not find on google how to work arround this….

Thanks

Patrick

3 thoughts on - CentOS6.8 And Python33

  • Even not knowing python, it’s fairly obvious – it says you need Python version 3.4 or greater for numpy 1.12.0, you’ve installed Python 3.3

    Generally, I don’t use pip for installing numpy – it’s such a common requirement for other packages that it’s in the repositories. Try something like

    yum install python33-numpy

    P.

  • Pete Biggs wrote:
    Using “yum install python33-numpy ” could be a solution for numpy but this just forward the problem to the next package I have to install with pip. I do not understand why a python 3.3 environment try to install incompatibles packages.

    I tryed to install python34 with yum but it does not seem to work with scl environment…. (yum install python34-setuptools python34)

    Patrick

  • Current versions of numpy seams to be not compatible anymore with python 3.3 :-[. I had to specify an older package version:

    pip install numpy==1.10.4
    as 1.12.0 doesn’t work anymore.

    Patrick

LEAVE A COMMENT