Dependency Issue

Home » CentOS » Dependency Issue
CentOS 1 Comment

yum update that to bring it up to 6.3 and then try and install…

One thought on - Dependency Issue

  • Hello List,

    I am trying to install php-snmp into my CentOS 6.2 system and it doesn’t work, and I am not sure why. It looks like it is trying to install php-snmp from 6.3. Error: Package: php-snmp-5.3.3-14.el6_3.i686 (updates)
    Requires: php-common = 5.3.3-14.el6_3
    Installed: php-common-5.3.13-1.el6.i686 (@anaconda-CentOS-201112130233.i386/6.2)

    Also why wouldn’t 5.3.13-1 be a higher revision than 5.3.3-14?

    [root@Z703108 ~]# cat /etc/redhat-release CentOS release 6.2 (Final)

    [root@Z703108 ~]# yum clean all Loaded plugins: fastestmirror Cleaning repos: base cr elrepo epel extras rpmforge updates Cleaning up Everything Cleaning up list of fastest mirrors

    [root@Z703108 ~]# rpm -qa | grep php php-5.3.13-1.el6.i686
    php-pgsql-5.3.13-1.el6.i686
    php-common-5.3.13-1.el6.i686
    php-ldap-5.3.13-1.el6.i686
    php-cli-5.3.13-1.el6.i686
    php-pdo-5.3.13-1.el6.i686

    [root@Z703108 ~]# yum –disablerepo=\* –enablerepo

LEAVE A COMMENT