Disable ZTS In Php

Home » CentOS » Disable ZTS In Php
CentOS 6 Comments

Hey guys,

I’m trying to disable ZTS in php, because an application we need
(AppDynamics) is not compatible with it.

So I tried compiling php with the following flags:

php -i | grep configure Configure Command => ‘./configure’ ‘–with-apxs2=/opt/apache2/bin/apxs’
‘–with-zlib=/usr’ ‘–prefix=/opt/php-5.6.8’ ‘–with-libdir=lib64’
‘–with-config-file-path=/etc’ ‘–enable-mime-magic’ ‘–enable-pcntl’
‘–libexecdir=/usr/libexec’ ‘–with-bz2’ ‘–with-curl’ ‘–with-gd’
‘–with-freetype-dir=/usr’ ‘–with-png-dir=/usr/lib64’
‘–enable-gd-native-ttf’ ‘–with-iconv’ ‘–with-jpeg-dir=/usr/lib64’
‘–with-zlib’ ‘–with-ldap’ ‘–enable-exif’ ‘–enable-sockets’
‘–enable-sysvsem’ ‘–enable-sysvshm’ ‘–enable-sysvmsg’ ‘–enable-wddx’
‘–with-kerberos’ ‘–enable-shmop’ ‘–enable-calendar’ ‘–with-xmlrpc’
‘–enable-soap’ ‘–disable-pdo’ ‘–with-openssl’ ‘–with-xsl’
‘–enable-dbx’ ‘–enable-mbstring’ ‘–with-mcrypt=/usr’ ‘–enable-bcmath’
‘–enable-pdo’ ‘–with-pdo-mysql=/usr’ ‘–with-mysql’
‘–with-mysqli=/usr/bin/mysql_config’ ‘–enable-zip’ ‘–enable-dba=shared’
‘–with-gettext=shared’ ‘–with-gmp’ ‘–enable-ftp’ ‘–with-pspell’
‘–with-config-file-scan-dir=/etc/php.d’* ‘–disable-maintainer-zts’*

And for some reason the AppD installer is claiming that ZTS is still enabled. So what I’d like to know is, did I disable ZTS correctly? If I did that means the problem is on the AppD side so we should take a look there.

Appreciate any help on this!

Thanks Tim

6 thoughts on - Disable ZTS In Php

  • on certain non-linux systems like MacOS i’ll run into a problem with the standard version of iconv in php. To leave it out i use the —without-iconv directive. Maybe give that a shot with maintainer-zts.

    Jeremy

  • Hey Jeremy,

    I’ll give that a shot. Thanks!

    Tim


    GPG me!!

    gpg –keyserver pool.sks-keyservers.net –recv-keys F186197B

  • This is really wrong way to do this. Install yum-utils and use yumdownloader –source package-name to get rhel version of package. Then modify spec file and recompile.

    Eero Hey guys,

    I’m trying to disable ZTS in php, because an application we need
    (AppDynamics) is not compatible with it.

    So I tried compiling php with the following flags:

    php -i | grep configure Configure Command => ‘./configure’ ‘–with-apxs2=/opt/apache2/bin/apxs’
    ‘–with-zlib=/usr’ ‘–prefix=/opt/php-5.6.8’ ‘–with-libdir=lib64’
    ‘–with-config-file-path=/etc’ ‘–enable-mime-magic’ ‘–enable-pcntl’
    ‘–libexecdir=/usr/libexec’ ‘–with-bz2’ ‘–with-curl’ ‘–with-gd’
    ‘–with-freetype-dir=/usr’ ‘–with-png-dir=/usr/lib64’
    ‘–enable-gd-native-ttf’ ‘–with-iconv’ ‘–with-jpeg-dir=/usr/lib64’
    ‘–with-zlib’ ‘–with-ldap’ ‘–enable-exif’ ‘–enable-sockets’
    ‘–enable-sysvsem’ ‘–enable-sysvshm’ ‘–enable-sysvmsg’ ‘–enable-wddx’
    ‘–with-kerberos’ ‘–enable-shmop’ ‘–enable-calendar’ ‘–with-xmlrpc’
    ‘–enable-soap’ ‘–disable-pdo’ ‘–with-openssl’ ‘–with-xsl’
    ‘–enable-dbx’ ‘–enable-mbstring’ ‘–with-mcrypt=/usr’ ‘–enable-bcmath’
    ‘–enable-pdo’ ‘–with-pdo-mysql=/usr’ ‘–with-mysql’
    ‘–with-mysqli=/usr/bin/mysql_config’ ‘–enable-zip’ ‘–enable-dba=shared’
    ‘–with-gettext=shared’ ‘–with-gmp’ ‘–enable-ftp’ ‘–with-pspell’
    ‘–with-config-file-scan-dir=/etc/php.d’* ‘–disable-maintainer-zts’*

    And for some reason the AppD installer is claiming that ZTS is still enabled. So what I’d like to know is, did I disable ZTS correctly? If I did that means the problem is on the AppD side so we should take a look there.

    Appreciate any help on this!

    Thanks Tim

  • I think command name is yum-downloader.

    Then modify spec and rpmbuild -ba specname.spec

    You need also modify version number a bit. Rebuilding is a bit issue as you need to recompile as security patches come out ..

    Eero
    30.10.2015 6.04 ip. “Tim Dunphy” kirjoitti:

LEAVE A COMMENT