Forcing Yum Update

Home » CentOS » Forcing Yum Update
CentOS 2 Comments

New to CentOS and running 6.6. I have previously installed gstreamer with plugins including libmodplug from rpmforge to listen to mp3 streams. Yum now tells me that a later version of libmodplug is available from epel but I am having problems forcing updating libmodplug from epel.

I have tried launching yum shell and then remove libmodplug, install libmodplug while having made sure epel is available. This after having read that it is a bad idea to use no-deps with yum. My attempt, however, fails with a not found message.

What would the correct approach be?

Thank you.

2 thoughts on - Forcing Yum Update

  • The correct approach would be to use yum-plugin-priorities, set rpmforge priority to a higher value (lower priority) than epel and run yum distro-sync.

  • Check if you have exclude=libmodplug in /etc/yum.repos.d/epel.repo and comment this line out.

LEAVE A COMMENT