Gambas Compile On Any Version Of CentOS

Home » CentOS » Gambas Compile On Any Version Of CentOS
CentOS 2 Comments

I’ve unsuccessfully been attempting to get Gambas to compile on CentOS 5.8. I’ve seen comment that it also doesn’t compile on CentOS 6.2. Has anyone gotten a successful compile of Gambas on any version of CentOS. I’d greatly appreciate hearing from you.

2 thoughts on - Gambas Compile On Any Version Of CentOS

  • Hello Casey,

    You will probably have a hard time getting this to build on C5 as a lot of build requirements are not available in the correct version, including the auto tools and qt4:
    http://gambasdoc.org/help/install?v3&view

    Even on C6 the autoconf version does not fulfil Gambas requirements
    (2.63 instead of 2.68), but then sometimes those requirements are set higher than they actually are, so you could give it a shot.

    You could use the spec file in http://CentOS.karan.org/el5/extras/testing/SRPMS/gambas-1.0.19-7.el5.kb.src.rpm as a base to start from. You might need to configure additional repos for build requirements like SDL-devel.

    And if you are looking for help it’s usually a good idea to provide specifics about where and how your build fails (grep -i the build log for strings like “warning”, “error” and “fail”) instead of the rather uninformative “I cannot get it to build”. It also helps to read documentation related to the build like the first link before you start building.

    Regards, Leonard.

  • Thanks for the info. Due to time constraints, I’ve elected to go the Qt route.

    — You will probably have a hard time getting this to build on C5 as a lot of build requirements are not available in the correct version, including the auto tools and qt4:
    http://gambasdoc.org/help/install?v3&view

    Even on C6 the autoconf version does not fulfil Gambas requirements
    (2.63 instead of 2.68), but then sometimes those requirements are set higher than they actually are, so you could give it a shot.

    You could use the spec file in http://CentOS.karan.org/el5/extras/testing/SRPMS/gambas-1.0.19-7.el5.kb.src.rpm as a base to start from. You might need to configure additional repos for build requirements like SDL-devel.

    And if you are looking for help it’s usually a good idea to provide specifics about where and how your build fails (grep -i the build log for strings like “warning”, “error” and “fail”) instead of the rather uninformative “I cannot get it to build”. It also helps to read documentation related to the build like the first link before you start building.

    Regards, Leonard.

LEAVE A COMMENT