Help With Thread CentOS 6.4 Won’t Reboot On Install

Home » CentOS » Help With Thread CentOS 6.4 Won’t Reboot On Install
CentOS 78 Comments

Newbie here. Need help with a thread that has about 25 posts. No replies in a few days. The thread is in software support for CentOS 6
and the subject of the thread is CentOS 6.4 won’t reboot on install. Have had limited success in getting a login screen but once I logout, I
can’t get back in again. It was mentioned in the thread that the problem is likely in Network Configuration. I have no GUI (gnome) no mouse, no terminal, and keyboard use only with Ctl+Alt+F2. Can login as root but have no luck getting the GUI to appear or to get a user login screen. Thanks in advance for your help.

Bob

78 thoughts on - Help With Thread CentOS 6.4 Won’t Reboot On Install

  • Robert Benjamin wrote:
    I think you need to take another entry-level course in English, in writing….

    Sounds like several problems, from what I can tell from the contorted para, above. First, you appear to have a problem with X. Does the correct driver *work*?
    Questions for this: what video card?
    do you have an /etc/X11/xorg.conf file (not subdirectory)
    if so, what driver is it showing?

    Next: you can’t log back in (as you?), but can as root.
    Questions for this: what’s in /var/log/secure after you’ve tried?
    Or /var/log/messages?
    what’s in your username entry in /etc/password for shell?


    Send me your physical address, and I’ll see if I can scrape up a blue book and pencil….

    mark

  • Questions for this: what video card? Video card is what came with Dell Inspiron PC. do you have an /etc/X11/xorg.conf file (not subdirectory) How would I find a file from that black F2 screen?
    Next: you can’t log back in (as you?), but can as root. Questions for this: what’s in /var/log/secure after you’ve tried?
    Ctl_Alt+F2 from gnome screen (screenshot posted in thread) gives me a login prompt on a text screen I assume. Can login as root there. Once I rebooted from there with Clt+Alt+ Del and got a GUI and logged in. When I closed it I was unable to log back in except with the Ctl+Alt+F2
    keys and this gets me back to a black screen with a login prompt and just the keyboard works.

    Or /var/log/messages? what’s in your username entry in /etc/password for shell?

    Have no way to find out what’s in /var/log/messages or in username entry in /etc/password for shell.

    The only things I can enter are on the black screen where I log in as root. Then have to write down the output, go to win7 and use email to reply to you and then back to CentOS if needed.

    I can’t even get a terminal screen to use for anything.

    Appreciate the satire, I can do that but it is a waste of time.

    Send me your physical address, and I’ll see if I can scrape up a blue book and pencil…. mark
    _______________________________________________ CentOS mailing list CentOS@CentOS.org http://lists.CentOS.org/mailman/listinfo/CentOS

  • I answered you on the forums … It seems that you just do not have a network connection (or DNS) working. With no network, GNOME is not happy (it can not properly resolve it’s name).

    So:

    1. You need to learn to use VIM to edit files and do so via ctrl-alt-f2.

    2. You need to edit /etc/sysconfig/network-scripts/ifcfg-eth0 and turn it on while booting

    3. If you do not have DHCP setup on your network for clients, then you need to setup the IP address manually and setup DNS manually in
    /etc/sysconfig/network-scripts/ifcfg-eth0

    once that is working, we can troubleshoot other things.

  • Robert Benjamin wrote:
    mouse, no

    Am I wrong, or do you not understand that the “black F@ screen” is a normal, standard shell window?

    if so, what driver is it showing?

    In the file that I mentioned, above.

    That’s a console window. And if you can log in as root, you can look at anything, including the files I’ve mentioned.

    What do you mean, you have no way to find out? Can’t you log in as root?
    I think you need to stop, and go read an introduction to Linux, since you seem to be telling me you have no idea what I’m talking about when I tell you what files to look at, nor how to look at them, nor how to save output. In fact, *if* I understand correctly, you seem to be telling me that you don’t have any idea how to use a command line.

    As a friend said once, “yo mama dresses you funny, and you need a mouse to delete files”

    mark

  • Wow! Hardly a friendly introduction for a newbie to Linux. Attitudes like this ensure users go scurrying back to Windows.

    As my mother used to say, “If you don’t have anything nice to say, don’t say anything”.

    Ben

  • Benjamin Donnachie wrote:
    I wasn’t going to waste another word on this thread, but I will respond to this: did you read the comments on other threads? Specifically, expecting a cheery overwhelming response, from people who are doing this while they’re at work, many working as admins (as I am, right now), without showing any evidence of having read man pages, read stuff, and googled on solving the problem, but treating us like paid support ain’t gonna cut it.

    Had you, for example, searched to find out a) how to look at a file, b)
    looked at the files I suggested you look at, or c) showed you’d done ANYTHING other than read my response and go, “duh, what’s that mean?”, I’d have been willing to work with you.

    And “don’t say anything”? Sorry, but if you don’t *tell* someone what they’re doing wrong, they’ll never change.

    mark

  • You seem to be getting your Benjamins confused. *I* am very familiar with Linux, have rescued more systems than I care to remember using single user mode and, frankly, rarely bother with a GUI.

    If you’re seriously that busy then get on with your day job and just leave the message to someone with more time who will give a better impression of the community.

    Ben

  • Benjamin Donnachie wrote:

    Sorry, I just glanced.

    What, I *shouldn’t* tell him what he’s doing wrong? Just try to do his job for him, and let him come back, again and again, without ever actually learning something?

    mark

  • Les Mikesell wrote:

    If he does. I mean, he kept complaining about the “black screen”, and appeared to have no idea how to look at the files….

    mark

  • I know what you mean, of course. But it’s sort of like telling someone to learn latin before they can understand english. Not an inherently bad concept but it shouldn’t be necessary.

  • Les Mikesell wrote:

    I dunno – I don’t think I was telling him to learn latin; rather, that he should increase his vocabulary beyond, oh, I read, years back, that the
    *average* American’s *average* vocabulary was about 500 words… and that Koko the gorilla had 550 in ASL….

    mark “eep, eep”

  • I had done some of the things you said. Did find out a) and b) and I think I posted output from cat
    /etc/sysconfig/network-scripts/ifcfg-eth0 in the thread. I know it is there in post 26. Trying to learn Linux at age 77 ain’t easy. The comments from different ppl will not send me scurrying back to windows. I have no probs with Ubuntu 12.2 nor Mint 14. Both installed on their own HDs the first time and I didn’t have to edit anything. Only CentOS
    is giving me troubles which is a surprising thing to me. Is this due to differences between Debian and PRM.

  • No, the problem is that you did not turn on networking when you did the install.

    Since networking is off, you have to get it turned on (or reinstall and turn it on this time).

    See this FAQ entry:

    http://wiki.CentOS.org/FAQ/CentOS6#head-b67e85d98f0e9f1b599358105c551632c6ff7c90

    and this screen on how to do it on an install:

    http://www.server-world.info/en/note?os=CentOS_6&p=install

    In the 8th step … you need to press the “Configure Network” button and you need to then check the “Connect Automatically” box (per the above FAQ link).

  • Hello Robert Benjamin Can you do the following?
    1) Start laptop until you get gnome.
    2) Instead of logging in hold down ctrl+alt+f1 (ctrl+alt+f7 to get back to window)
    3) This is your shell (bash by default) sort of like cmd in windows.
    4) log in as root

    most log files live here /var/log/
    Cat is a shell command: man cat if you want to know more (from shell)
    vi is like edit in cmd

    5) Push return and then type

    cat /var/log/messages |more

    That were a lot of apps including gnome report.

    cat /var/log/messages |grep fail

    I’m guessing your problem is not gnome but x windows (X11)

    type: X -probeonly >& startx.out

    dmesg |grep fail

    Redhat say laptops are the hardest to support. They say they start here.

    http://www.linux-on-laptops.com/dell.html

    Redhat docs

    http://www.redhat.com/support/resources/faqs/rhl_general_faq/FAQ.html

    https://access.redhat.com/knowledge/docs/Red_Hat_Enterprise_Linux/?locale=en-US

    Have you got a wireless network up ?
    http://wiki.CentOS.org/HowTos/Laptops/Wireless

    man iwconfig

    My two pennies. I think your CentOS is running fine. You have a problem with X or Gnome.

    I’d do this. (assumes you have a network conection)

    init 3
    yum groupinstall XFCE
    init 5

    Select user from select box. Before entering password look down(bottom middle of screen and select gnome xfce) log in.

    If you still have a fail, points to X (X.org )

    Hope this helps. Paul

  • This is a list not personal email. Just ignore it if it upsets you and let someone with more time / patience / manners pick it up.

    Ben

  • Had read this FAQ many times and clicked “Configure Networking” and selected system eth0 and connect automatically. Bottom line is that it booted once but not a second time after logging off. Mentioned this I
    think. So that is where I have difficulties. In FAQ 2 above, the ‘will start on boot in the future” is what id doesn’t do. I can re-install again if that’s necessary and hope it works this time.

  • If you can log in and use an editor in character mode you can fix it. The change needed in /etc/sysconfig/network-scripts/ifcfg-eth0 will be obvious once you get that far. But, it might be easier to reinstall if you don’t know how to do that. Since it is a new install anyway you won’t lose anything.

  • In the CentOS forum under Software Support is my thread: CentOS 6.4
    won’t install on reboot. Post number 27 or 28 lists the output I got from FAQ2 above from cat /etc /sysconfig/network-scripts/ifcfg-eth0 My guess is the most important line there is ONBOOT=yes Anyway, there are suggestions in the forum which I will follow and then post the results back to the forum. Thanks again.

  • The median adult native English with high-school education has about
    11,000 stem words from which perhaps 40-50k derivative words are formed. Technical jargon aside, one only requires about 6000 root words to comprehend the essence of approximately 90% of all written English text.

    A native English speaker acquires about three new stem words per day or over 2500 per year.

    But, evidently one may be a boor with any size vocabulary.

  • Yes, the ONBOOT=yes is already there. However, some of the other parts of that thread make me think that your network interface actually comes up but you are not getting a DHCP address or the DHCP
    server supplies a DNS server address that does not work. These would usually be supplied by your internet router. Are you confident that it is set up correctly?

    The reason I think this is the problem is the post where you said you could log in after a very long delay. About the only thing that can cause a very long delay is the system waiting for DNS responses on what it thinks is a working network interface. The next things needed for further diagnosis would be the output of the ‘ifconfig’
    command after you are able to log in, and the results from ‘cat
    /etc/resolv.conf. The first should show the IP address assigned by DHCP from the router, and the second will have the DNS nameserver address(es).

  • In the last post on the forum is the output of ifconfig. It closely resembles what was shown there and stated that my output should resemble the one already there in post 29 ,and it does. There was no suggestion to try cat /etc/reslov.conf. Can do that from the root login. Will wait til I get a reply from the forum. Plenty of suggestions from here and the forum and I’ll keep up with both. The delay was almost an hour BTW. Thanks again. The router works perfectly fine and quickly for win 7, Ubuntu 12.2 and Mint 14.

  • Robert Benjamin wrote:


    Quick question – I missed the very beginning: what does ethtool eth0 show?
    Is there a link? Or does this have em1?

    mark

  • The IP address looks like what you would get from a typical home router, so that’s probably OK. A quick test for DNS would be the
    ‘dig’ command. If it quickly returns a screenfull of root nameservers and addresses, then DNS is not the problem. If it doesn’t, then check what you have in your /etc/resolv.conf file.

  • OK, never mind about DNS. And on a 2nd thought, the delays it causes would be early in the startup where sendmail/samba, etc. start. Not sure why the Gnome desktop would wait for anything. I thought all it needed was the localhost entry in /etc/hosts to satisfy the need for a hostname..

  • Robert Benjamin wrote:

    Nasty thought: in one window, run tcpdump -A port 50, and in another, try looking something up, say, nytimes.com, something obvious. See what’s going and coming.

    mark

  • tcpdump -A port 50 output is tcpdump: verbose output suppressed, use -v or -w for all protocol decode listening on eth0, link-type EN10MB
    (Ethernet), capturing size 65535 bytes, and a blinking cursor which I
    left for 20 min and re-started, tried with -v got listening on eth0, type EN10MB (Ethernet), capture size 65535 bytes. re-started and meant to use -w but forgot and just typed tcpdump. That gave tons of output which I can’t fathom and let it go for 30 minutes. Re-started one more time and pinged nytimes.com That returned screenful of data packets all ok. Then shutdown til tomorrow.
    Bob

  • I think he meant port 53 instead of 50 to catch the DNS exchange –
    which now sounds like it is working anyway. When you start, does gnome eventually work normally now?. I’d do a ‘yum update’ on general principles if you at least have the network running.

  • Les Mikesell wrote:
    Thanks, Les, that was what I meant. I’ve been snowed under all week, and more so today: it’s not one thing after another, it’s three things all at the same time….

    mark

  • tcpdump with port 53 was no different than with port 50.
    Waited an hour after startup and still had that same blue screen. Is that the gnome desktop screen? So no it doesn’t eventually work. An hour is eventually right? :-)
    yum update installed 23 packages successfully.
    Should I re-instal again? It will be the 3rd time.

  • Robert Benjamin wrote:
    which I
    packets

    Mmmm, another nasty thought…. I just went, and found your original post, where you said you’d done an install using minimal. I’m, well, let us say underwhelmed by “minimal” – I have to add stuff on a headless server to get online.

    What’s your goal here – is it to have a working desktop environment? If so, and you have not done so yet, there’s an option for desktop; I’d install that, though you can always choose that, then check “customize now”, and add or subtract things.

    With minimal… I’d have to sit at your keyboard and figure out what’s missing.

    mark

  • I corrected that minimal install by starting over from a DVD with a full install and ticking the Gnome GUI. It did once after the long wait let me log in to CentOS 6.4 with gnome and I could use it, instead of win 7 for browsing, email etc.

    What’s your goal here – is it to have a working desktop environment? If so, and you have not done so yet, there’s an option for desktop; I’d install that, though you can always choose that, then check “customize now”, and add or subtract things.

    Goal is to use CentOS 6.4 with gnome as my OS and not win 7. Yes, I’d like a working desktop environment with FF and TB and other programs, Libre Office, Gimp etc Did the customize now on last time I
    re-installed. Now I’m still trying to get online. I had things set up on the desktop the last time it let me log in and I want to get back there in a reasonable time frame. Just like to use CentOS as I can win 7 or Ubuntu or mint 14. It just doesn’t want me to log back it anymore. :-(

  • Just a thought. Would it help if I did yum install KDE, and then yum remove gnome? Reason is that I see on the different fora some pro/cons with Gnome and KDE. Since Gnome won’t let me back in is it worth a try? Bob

  • I thought you said you had Gnome to a point where you could log in. If you get that far I’d stick with it because it is the default desktop and there will be more people with similar configurations to help sort out any other problems. If you did get to a login once but can’t now, please describe what you did to make it work before.

  • Robert Benjamin wrote:

    you can always install KDE and try, but there’s no reason to uninstall gnome (they can coexist peacefully).

  • Things never work very well for me before having coffee either, but that’s probably not the real solution. So when you established that your network and DNS was working, Gnome was working too? Can you log in on a virtual character-mode terminal session (control-alt-F2) and try the ifconfig and dig commands again? If everything appears to work there, I’d try a ‘yum update’ just on general principles.

  • Sure. Will do dig and ifconfig again. Did yum update this morning,
    23 packets updated .Worked fine. You need the output from dig and ifconfig again?

  • No, if yum update worked we know the network is OK. What happens if run ‘init 3’ (should shut down the partly-working X session), and then
    ‘startx’ which will start a new one under your existing login?

  • init 3 it did shutdown the partly working X session. Several line flashed on screen and 2 had FAILED at end of line. Too fast to readtwhat it said.
    startx Fatal server error:
    Server is already active for display 0
    If the server is no longer running, remove /tmp/
    .X0-lock and start again.
    I did yum remove /tmp/ .X0-lock. It removed 17 packages and then I did startx (again) Got the same re: remove /tmp/ .X0-lock. One other line I saw Unable to connect to X server was present in output of startx.

  • That should have just been an ‘rm /tmp/.X0-lock’ (a file, not packages). Not sure how much damage has been done at this point. If you know the package names, try to ‘yum install’ them back again. And rm the file, and try startx again.

  • Robert Benjamin wrote:


    I’d leave gnome – there’s a few programs it provides I like, like gwenview, which I think is gnome, and we won’t mention freecell or mines…

    However… thinking about this, now that I’ve got a chance to catch my breath here at work… a couple of years ago, I think it was, I updated a fedora box here at work to 13? 14? and gnome was hosed, as in the gui would come up, but instead of a window with a login, all I had was about a pencil point width by about six inch high – the hight of the login box, and I never was able to get it to actually give me the login. I wound up having to pull out gnome, because I couldn’t find a way to force a KDE
    login.

    Anyone know what the current replacement is for switchdesk?

    In the meantime, here’s another thought: you could try to yum groupremove and groupinstall Desktop, which I think is gnome, to see if there’s some configuration files that are mangled.

    The one time you did log in – did you change any settings?

    mark
    mark

  • Les Mikesell wrote:

    It’s always a problem, if there’s too much blood in your caffeine stream….

    Ok, first, as Les said, NO! Just rm the file. Now, to reinstall what got yum removed, look at /var/log/yum.log, and it’s the last bunch of stuff, nicely timestamped, so you won’t accidentally go too far.

    Then, take a look at /var/log/Xorg.0.log, and you’ll be able to see, at the bottom, what it was trying to tell you.

    Note: if you haven’t figured it out yet, all the system-related logs are in /var/log/.

    Note 2: find a copy of Fraesch’s Essential Systems Administration, published by O’Reilly. I know the last update was ’03; doesn’t matter. Read chapter 1 and *esp* chapter 2, “The Unix Way”, which will give you a really, really clear picture of how the whole thing hangs together, and the rationale behind why the filesystem is the way it is.

    Finally, I’ve seen so many issues over the years, that at home, I run at runlevel 3, and have startx in my .bashrc. Doing it that way, if you have problems, when you hit , you’re back at your command line, and you can look to see what was wrong with X. If you do want to stay at runlevel 5, work it out this way, and once you’ve got it fixed, you can do so.

    mark
    mark

  • Agreed. If you edit /etc/intiitab and change:
    id:5:initdefault:
    to id:3:initdefault:
    the system will not start X or a GUI desktop at bootup and you would log in in character mode. After logging in, ‘startx’ will start up X
    and your desktop session. I was hoping this might display a better diagnostic for whatever problem you have – and as Mark says you can easily kill it and drop back to the character mode session.

  • Thought it was not a good idea to use yum remove …. but had to try. In my head I could see you asking me to try it and I should have TRIED something, not just sit here. Well, hopefully I can put those packages back as you said, tomorrow. Will look for Fraesch book. Thanks for the suggestion. Not sure if I’m at runlevel 5 .It’s at whatever it was set at during the install. Never changed any settings unless told to. In the one login I only installed FF, TB, Calc Gimp etc from the Applications menu .Entered email addys and bookmarks and logged out thinking I’d be OK to get back in again. HA!

  • Default install would be runlevel 5, at least if you include desktop components. And your assumption that you would be able to log in again wasn’t bad – you seem to have some very unusual issue that no one else has.

  • On Thursday, 28 March 2013 @19:31 zulu, m.roth@5-cent.us spake thusly:

    I don’t think that would help, since (if I recall correctly,) its picklists don’t appear along the bottom until you click ‘in’ the logon dialog.

  • Having an issue that no one else has makes me feel good in a way. At least I didn’t do something incredibly stupid ( that we know of
    yet), and on the other hand, it isn’t encouraging either. Will try and add the packages I removed as you suggested and then use rm /tmp/
    .X0-lock and hope it lets me log in. Bob

    (At the center of a black hole is a man with a flashlight, running around looking for a circuit breaker.)

  • looked in /var/log/yum.log and /var/log/Xorg.0.log permission denied
    chmod a+x OK got list of time stamped and at bottom I tried yum install
    one of the items there. Got ‘no package name ‘. tried rm /tmp/ .X0-lock gives ‘/tmp is a dir. Did cd /tmp/ .X0-lock and ls several files and subdirs (?) but no X0-lock. Noticed var there so cd /var and ls cd tmp got ifcfg-eth0.swp and also benjie1-HnQ9gw adjacent to the .swp BTW benjie1 is my user login. Tried again to find .X0-lock and no luck. Hope I didn’t make things worse. Yum update said no packages set for install and yum install (from time stamped items) said ‘no package available’ with the name and numbers from a time stamped line picked at random.
    Have a GREAT Easter Holiday. Thanks so much for your patience and hlp. Greatly appreciated. We will get this to work, Right!

    Bob

  • You need to do most of this as root. Carefully…

    ^^no space there.

    The shell breaks commands on white space.

    You actually did a cd /tmp.

    Your are looking for /tmp/.X0-lock. Another convention is that files starting with a . are ‘hidden’ in the sense that ls will omit them unless you use the -a option.

    Your yum remove command may also have been interpreted oddly if you had the space after /tmp. Normally you would just give the base package name to install, stopping before the -version-number part. For example if your log says yum removed gnome-disk-utility.i686
    0:2.30.1-2.el6 you would get it back with yum install gnome-disk-utility.

  • Yes I did cause it said tmp is a dir so I thought I would find something there but no luck. I tried.
    so just what should appear after I type rm /tmp/.X0-lock Any output expected?
    I never got a nice neat list lie what you have above .Maybe I had another error when I tried to look in /var/log/yum.log What is the best command to use to look in here? Thanks . Have a great Easter Holiday. Bob

  • Robert Benjamin wrote:

    For administration, either log in as root, or sudo -s, which will make you root (but leave a trail in the logs of what you did… which might be helpful for oopses.

    Just about everything in /var/log is root-only readable. You shouldn’t change that, for security reasons.

    Right. One of the few things that really annoys me about Linux is that the old std, at least where I worked, for ll was ls -laF, *not* ls -lF. I
    really *do* want to see hidden files, and the permissions/ownerships of the directories I’m looking at.

    If you’d find that convenient, edit your .bashrc, or whatever, to add alias ll=”ls -laF”

    I’ve also not seen anywhere that h=history wasn’t the case, except for linux….

    tail /var/log/yum.log or view /var/log/yum.log

    DO NOT EDIT IT… which is why I used view, to default to uneditable. You can, of course, force it, but it warns you.

    mark

  • That’s an oddly complicated question. Normally rm does what you tell it quietly. If it failed you’d see an error message but nothing on success. However, when you log in as root you get a shell alias that runs ‘rm -i’ when you type rm. That is the ‘interactive’ option that makes it prompt before actually removing. But depending on whether you were root, or how you got there, the alias may or may not be active.

    Anyway, the short story is that if you didn’t get an error message, the file should be gone. And now you can try ‘startx’ again. What you accidentally removed may not affect the desktop.

    I usually use ‘less’ to view files, because the controls are the same as vi. So capital-G to go to the end, b (or up-arrrow) to go backwards, ctl-b by pages, q to quit.

  • as root. first did rm /tmp/.X0-lock got remove regular file
    ‘/tmp/.X0-lock’? – typed y and got back to the root login prompt where I started. Guess that was ok.

    Next typed cat /var/log/yum.log Got the list you mentioned, and the date where I made the error had things marked with ‘erased’. It was as long as the list I erroneously removed, so I did yum install filename for each one and they all worked. Here is the list that was re-installed:

    then, typed /var/log/Xorg.0.log and at the bottom it listed the files above as ‘installed’. The same ones that were previously marked as
    ‘Erased’ So hopefully that is good. Had to shut down and do errand and back now but haven’t tried anything yet.

    Bob

  • You’ll be back where you started after a reboot if you didn’t change inittab to start at runlevel 3. That is, if you do the ‘init 3’ and X doesn’t shut down cleanly you will have to remove the lock file again. But at least you’ll know what is going on if ‘startx’
    complains. You may or may not hang in the same way when starting via ‘startx’ so try to watch for any error messages that might flash by first.

  • So when I put the HD back in the PC it will boot up and I can wait and see if it allows me to log in> (HA!) If not, then Ctl+Alt+F2 and login as root and try startx and see what it does. I didn’t change inittab ever since this whole senario started. Is default to start at runlevel 5? Bob

  • Yes, installs that include X and a desktop will default to runlevel 5. Before trying ‘startx’ , do ‘init 3’ as root. That should shut down the existing session, but whatever is hanging on startup may prevent a clean shutdown too. So startx may complain that there is still a lock file and you may have to remove it manually and run startx again.

  • Just to be sure, do ‘init 3’ by editing /etc/inittab with gedit and change the runlevel to 3 from 5. Number only. Save and reboot or shutdown and re-start. Then as root, try startx and remove a lock file if it says one is there.
    Question: if it starts at runlevel 3 can I log in on a GUI or is it in text mode. If the latter is the case, I assume I can log in as user and I should get a GUI so I can use FF, TB etc. Right? And then eventually I
    need to get back to runlevel 5 as a permanent login procedure … someday!

  • Init 5 starts X and a GUI-type login process. When you log in, it starts your GUI desktop. In runlevel 3, you log in in character mode, but ‘startx’ will start X, then your desktop and after that it is all the same. Except that with the startx approach, if anything goes wrong you can to kill the X session and you will drop back to the parent character mode login where you can check the logs and try again.

  • WELL, I don’t know what to say. I just put the HD in the PC turned it on and was waiting for the blue screen so I could login as root and type ‘init 3’. BUT, guess what happened. A tiny clock appeared at the top left followed by a log in screen and here I am. Happened very quickly. A few seconds. Now, do I dare log out and try to get back or just wait for a reply from you. Yesterday I never did init 3 either. Maybe it is the Easter Bunny. I don’t know. I’m a bit apprehensive about shutting off and trying again. What’s your opinion?

    Bob

  • That’s the way it is supposed to work, and since no one recognized the previous symptoms my best guess is that it was some sort of hardware issue. Maybe swapping the drive left a bad connection to the disk or network.

  • Saga continues. re-booted from GUI and it went to blue screen. Shut down and returned in about 2 hours and turned it on and it worked again. So I guess from what you say this is the way it will be. Unless I shut down from GUI vs. rebooting. BTW, System/Network Connections shows empty box. System/Network Proxy shows box with Location:Default and tick in
    ‘Direct internet connection. Everything else is greyed out. Thanks.

    Bob

  • Looking for the book you recommended by Fraesch: Essential Systems Administration. Tried a local Barnes and Noble store and the author’s name is different. They have it as Frisk, same title. Third Edition. Hope it’s the same book. Can you double check please. I assume this is at a level I can deal with. Thanks.

    Bob

  • Thanks. I’ll browse the bookstore for books from O’Reilly Publisher and see what appeals to me. Texts can be boring as I well know as an Assoc Prof, retired, and many are sooo borrrring it is a shame. Anyhow, will look and I’m sure I’ll find somethig suitable.

    Bob

  • I don’t’ know anything about this book or publisher, but you really need to learn in several different levels. One is the broad overview of what you are trying to do (and once you understand that, you won’t want to revisit the theory every time you want to change some detail), another is the choice of OS/application programs and languages you are implementing (which may change, but relatively slowly), and another is the very version-specific details you need when you actually start changing things. I’ve never found a single book that could combine those levels in a way that works together at all or could avoid being out of date before it is printed. You really need a tutorial that you’ll read once and throw away, plus a reference for the details you’ll change. And for the reference side, the online man pages work, once you learn to read them and understand that they expect you to already know what the shell will do to command lines
    (wildcard/variable substitution, redirection, etc.) before the program itself runs. And the RHEL/CentOS docs are good too.

  • I recall from arlier in the thread that the OP din’t know his run level. So after a decent interval with no one suggesting it …

    $ runlevel
    3 5

    The first digit is prior run level, the second is current.

    HTH, Bill

  • Les Mikesell wrote:
    ago,

    Les, you don’t know O’Reilly? I’m shocked, shocked I tell you. Almost every programmer I know, and every admin, had somewhere between one O’Reilly book and a full shelf of them. (No, I’m not getting a kickback from O’Reilly).

    He became a publisher, as I understand, in the late eighties, when he put out five volume set, co-written by him, on working with and programming X. They actively encourage group book buys – I’ve both participated in them, and once set up one, back in the nineties (never again, trying to get 20 or so folks to pass in the selections and money….). The discounts hit very quickly, starting at 10 books (10%? 15%?) and once you go over 50
    books, I think, from there to 199 books, it’s a 45% discount off cover.

    I know he’s in wikipedia….

    mark

  • Oh sorry, I missed that. Yes, I do respect O’Reilly as a technical publisher (and have enjoyed the OSCON conferences several times). But, these days there are so many books on so many topics that even being published by O’Reilly isn’t a guarantee that one will meet any particular needs.

  • Have inconsistency in getting it to let me login. Yesterday no luck. At ‘$ runlevel’ got 5 3 so it must have been at runlevel 3. startx no help, back to blue screen. Today, just started it first time and it booted right to GUI login screen. All is OK that has been set up like email, FF, printer etc. Checked Pref/System/Network Connection and the box is greyed out. Pref/SysytemNetwork Proxy only ‘Direct Internet connection’ is ticked. Everything else is greyed out. Ran updates also. This happened a few days back and was fine as long as I stay logged in. Re-boot or shutdown was not good. Couldn’t log in again. Then surprisingly today it is back. WTF ? Other HDs are OK and work reliably.

    Bob

  • It’s hard to make sense of random behavior. I’d still guess it is some hardware-related issue. You might get a hint from
    /var/log/messages if you look at what happened (or didn’t) when it is hung compared to older startups that worked, but there will be a lot to wade through.

  • Just a random thought that may trigger something in the wider brain trust:

    At various times you have mentioned that you had “shutdown”. How did you do a “shutdown” both from Gnome and from the terminal?

    The reason I ask is that Linux supports more than one kind of “shutdown”, but they are not all equal.

    The safest one is labeled something like “Turn Off Computer” (on KDE, not sure what wording Gnome uses) or you type “halt” at the command line, and it takes a good part of a minute to shut down. On many computers you can achieve the same effect by pressing the power button for LESS than half a second (quick poke).

    For some laptop users, just shutting the lid on the laptop is how they do a
    “shutdown”. This does NOT shut down the computer, but just puts into
    “suspended animation”. When you wake it up, it tries to resume where it was before you shut down. This is also sometimes labeled “hibernate” on GUI screens (I have not idea how to do it from the command line).

    Hibernation works well on some laptops, but is very problematic on other laptops. Basically Linux tries to make a complete record of how everything was set when it is commanded to hibernate, then write its entire memory contents onto disk, then take a nap. When you wake it back up it tries to restore its memory from hard disk, and put all the hardware back the way it was before. Laptops are notorious for having special hardware, specific to a particular model, that has some secret setting that has to be restored. Until the kernel maintainers find out about and accommodate each of those secret settings, the laptop may get out of bed on the wrong side, and be very contrary. For this reason, whenever you are having any kind of problems, one of the first things to do is to NEVER do anything except turn it off all the way with a full, long shutdown.

    Another (problematic) way to “shutdown” is to hold down the power button for about 5 seconds. This is equivalent to wanting someone to go to bed, but they don’t want to, so you hold your hand over their mouth until they pass out, lay them in a bed, and say they “went to sleep”. Yes, the computer is “shutdown”, but it didn’t have time to do it in an orderly manner, and so there may be a mess to clean up when you power it back up.

    This may be entirely irrelevant, but if not, it may be helpful, especially when you sometimes seem to be describing a situation where you only can get into gnome if the last time you shut down you were using the command line.
    Also, the one time you described the computer starting up very quickly–this is the (desirable) characteristic of hibernation. If your
    “shutdown” is different from the command line than it is from the GUI, then you may be facing a hibernation (or similar) problem.

    Ted Miller

LEAVE A COMMENT