How To Update Glib-2.28.8 To Glib-2.40.0 Or Newer Version

Home » CentOS » How To Update Glib-2.28.8 To Glib-2.40.0 Or Newer Version
CentOS 2 Comments

Hi,

I’m trying to build gstreamer sdk on CentOS 6.7. When configure is run for ‘gstreamer-1.8.2.tar.xz’ on CentOS 6.7, error messages are reported as below:

checking for GLIB… no configure: Requested ‘glib-2.0 >= 2.40.0’ but version of GLib is 2.28.8
configure: error: This package requires GLib >= 2.40.0 to compile.

The command of ‘yum install glib*’ can only update glib to glib-2.28.8. How to update glib to the version of >=2.40.0 on CentOS 6.7?

Thanks!

Regards

Andrew

2 thoughts on - How To Update Glib-2.28.8 To Glib-2.40.0 Or Newer Version

  • You’re going to have to support your own version of glib (and not replace the OS one) to get that working, most likely. You might have better luck getting the latest gstreamer to build on CentOS7, which has glib2 2.42.2 packages.

    CentOS (particularly, CentOS6 or CentOS5) isn’t the best platform to be building the latest versions of software like gstreamer, which is already packaged and maintained at an enterprise level.

LEAVE A COMMENT