Lets Talk Abaut Gstreamer 1.10.5, Gstreamer-libav, Ffmpeg, Bluray And Vlc

Home » CentOS » Lets Talk Abaut Gstreamer 1.10.5, Gstreamer-libav, Ffmpeg, Bluray And Vlc
CentOS No Comments

Hello guys,

my playground this days with gstreamer resources can be found at:

http://CentOS.cms4all.org/repo/7/gstreamer/

The best thing for CentOS I think to compile the given one by gstream libav:

Has ffmpeg 3.2.5 not ffmpeg 2.8.13 what is the background for vlc. In principal it’s possible to build ffmpeg 3.4.

http://CentOS.cms4all.org/repo/7/gstreamer-ffmpeg3/

vlc 2.26 is only compatible with ffmpeg 2.8.xx release.

Hopefully i get response from the gstreamer guys to get bluray running with gstream-libav. In the past it was possible with gstreamer 1.4.5.

As a side node as always: Got problems with dvd on usb blurayplayer, but this is another storry and can not be fixed from the kernel side. Buffer problems. Blurays & DVD (builtin drive) are playing with vlc. Totem can play anything, exclude bluray.

http://CentOS.cms4all.org/repo/7/media/

Another little problem is vlc 3.0 can only compiled with gcc 4.9 and upper. Has to be rearrange for static gcclib, no real dependency by installation. http://vault.CentOS.org/7.4.1708/sclo/Source/rh/devtoolset-3/
Not yet on my todo list. Why 4.9? No g++ binary break.

Bluray taken from my libbluray1 rpm otherwise i brick gvfs (bluray
0.2.3). Recompiled test wise. Think about to write a mail to redhat.

Yes I replace the complete gstreamer 1.10.4 with 1.10.5, because of minor update.

The original package was gstreamer-libav-0.6. It was complete inpossible to play anything good in totem.

What do you think ?

Sincerely

Andy

PS: I’m tired. Please forget my bad english this days…

LEAVE A COMMENT