Lirc 0.9.0

Home » CentOS » Lirc 0.9.0
CentOS No Comments

Does anyone have any experience getting LIRC 0.9.0 up and running on CentOS 6.6?

I have the packages from EPEL installed:

lirc.x86_64 0.9.0-8.el6 @epel lirc-doc.x86_64 0.9.0-8.el6 @epel lirc-libs.x86_64 0.9.0-8.el6 @epel lirc-remotes.x86_64 0.9.0-8.el6 @epel

And my IR driver loads fine and creates /dev/lirc0:

IR NEC protocol handler initialized IR RC5(x) protocol handler initialized IR RC6 protocol handler initialized Registered IR keymap rc-rc6-mce input: Media Center Ed. eHome Infrared Remote Transceiver (0471:0815) as
/devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0/rc/rc0/input12
rc0: Media Center Ed. eHome Infrared Remote Transceiver (0471:0815) as
/devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0/rc/rc0
mceusb 5-1:1.0: Registered Philips eHome Infrared Transceiver on usb5:2
usbcore: registered new interface driver mceusb IR JVC protocol handler initialized IR Sony protocol handler initialized lirc_dev: IR Remote Control driver registered, major 247
rc rc0: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0
IR LIRC bridge handler initialized

I added LIRC_DEVICE=”/dev/lirc0″ to /etc/sysconfig/lirc. I have my configuration in /etc/lirc/lircd.conf that was working with LIRC 0.8.6.

But when I run irw, I get no output.

I do see in the log:

Jun 1 06:04:04 marble lircd-0.9.0[1787]: lircd(default) ready, using
/var/run/lirc/lircd Jun 1 06:06:08 marble lircd-0.9.0[1787]: accepted new client on
/var/run/lirc/lircd Jun 1 06:06:10 marble lircd-0.9.0[1787]: failed on bit 1
Jun 1 06:06:10 marble lircd-0.9.0[1787]: failed on bit 1

And a whole bunch of failed on bit messages.

Does anyone have any ideas?

LEAVE A COMMENT