Lvm Snapshot Problem

Home » CentOS » Lvm Snapshot Problem
CentOS No Comments

Hi list,

i have an error when i do an lvm snapshot.

The error is like this when i use the command “/sbin/lvcreate -L20G -s -n
/dev/vgraid/vm” :

*semid 5013504: semop failed for cookie 0xd4d23a8: incorrect semaphore state*
* Failed to set a proper state for notification semaphore identified by cookie value 223159208 (0xd4d23a8) to initialize waiting for incoming notifications.*

I use CentOS 7 with this packages:

# rpm -aq | grep kernel kernel-3.10.0-123.9.3.el7.x86_64
# rpm -aq | grep lvm2
lvm2-libs-2.02.105-14.el7.x86_64
lvm2-2.02.105-14.el7.x86_64

I read that the problem is related to udev :

# zgrep UEV /proc/config.gz CONFIG_UEVENT_HELPER_PATH=”/sbin/hotplug”

# grep UEV /boot/config-3.10.0-123.9.3.el7.x86_64
CONFIG_UEVENT_HELPER_PATH=””
CONFIG_DM_UEVENT=y

I can not understand the problem.

The server is in a server farm with a lot of VM running I would like to solve the problem without restarting the server.

Could you help me?

Thanks.


——————————————————–

Cristian Del Carlo

Il testo e gli eventuali documenti trasmessi contengono informazioni riservate al destinatario indicato. La seguente e-mail è confidenziale e la sua riservatezza è tutelata legalmente dal Decreto Legislativo 196
del 30/06/2003 (Codice di tutela della privacy). La lettura, copia o altro uso non autorizzato o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere, immediatamente, alla sua distruzione.

——————————————————–

LEAVE A COMMENT