Minimal ISO: GRUB UEFI Has Incorrect Config

Home » CentOS » Minimal ISO: GRUB UEFI Has Incorrect Config
CentOS 2 Comments

Hello,

I’ve just tried to use CentOS-6.4-x86_64-minimal.iso, but it does not work unmodified.

The grub commands used by the ISO for installation/rescue are:

kernel /images/pxeboot/vmlinuz …
initrd /images/pxeboot/initrd.img

These paths do not exist on disk.

If I manually correct these to:

kernel /images/vmlinuz …
initrd /images/initrd.img

The installation is able to proceed normally.

Thanks,

Adam Bishop Systems Development Specialist

gpg: 0x6609D460

Janet, the UK’s research and education network.

Janet(UK) is a trading name of Jisc Collections and Janet Limited, a not-for-profit company which is registered in England under No. 2881024
and whose Registered Office is at Lumen House, Library Avenue, Harwell Oxford, Didcot, Oxfordshire. OX11 0SG. VAT No. 614944238

2 thoughts on - Minimal ISO: GRUB UEFI Has Incorrect Config

  • Hi Adam,

    Can you file this as a bugreport on bugs.CentOS.org please ? I suspect the issue might be that on the distro the images in pxeboot/ and in just images/ are linked to each other ( and to /syslinux/ ) and we might have skipped / missed something in the tests

  • Looks like someone already has:

    http://bugs.CentOS.org/view.php?idc21

    Thanks,

    Adam Bishop Systems Development Specialist

    gpg: 0x6609D460
    t: +44 (0)1235 822 245
    xmpp: adamb@jabber.dev.ja.net

    Janet, the UK’s research and education network.

    Janet(UK) is a trading name of Jisc Collections and Janet Limited, a not-for-profit company which is registered in England under No. 2881024
    and whose Registered Office is at Lumen House, Library Avenue, Harwell Oxford, Didcot, Oxfordshire. OX11 0SG. VAT No. 614944238

LEAVE A COMMENT