Multipath

Home » CentOS » Multipath
CentOS No Comments

I have inherited a system set up with multipath, which is not something I
have seen before so I could use some advice

The system is a Dell R420 with 2 LSI SAS2008 HBAs, 4 internal disks, and a MD3200 storage array attached via SAS cables. Oh and CentOS 6

lsblk shows the following:
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sdd 8:48 0 931.5G 0 disk
├─sdd1 8:49 0 931.5G 0 part
└─mpathi (dm-0) 253:0 0 931.5G 0 mpath sdc 8:32 0 931.5G 0 disk
├─sdc1 8:33 0 1000M 0 part /boot
├─sdc2 8:34 0 31.3G 0 part /
├─sdc3 8:35 0 31.3G 0 part [SWAP]
├─sdc4 8:36 0 1K 0 part
├─sdc5 8:37 0 184.5G 0 part /home
└─sdc6 8:38 0 683.6G 0 part /data01
sde 8:64 0 931.5G 0 disk
├─sde1 8:65 0 931.5G 0 part
└─mpathj (dm-1) 253:1 0 931.5G 0 mpath
└─mpathjp1 (dm-8) 253:8 0 931.5G 0 part /data02
sdf 8:80 0 931.5G 0 disk
├─sdf1 8:81 0 931.5G 0 part
└─mpathk (dm-2) 253:2 0 931.5G 0 mpath sda 8:0 0 51T 0 disk
├─sda1 8:1 0 12.8T 0 part
├─sda2 8:2 0 12.8T 0 part
├─sda3 8:3 0 12.8T 0 part
├─sda4 8:4 0 12.8T 0 part
└─mpathe (dm-3) 253:3 0 51T 0 mpath
├─mpathep1 (dm-4) 253:4 0 12.8T 0 part /SAN101
├─mpathep2 (dm-5) 253:5 0 12.8T 0 part /SAN102
├─mpathep3 (dm-6) 253:6 0 12.8T 0 part /SAN103
└─mpathep4 (dm-7) 253:7 0 12.8T 0 part /SAN104
sdb 8:16 0 51T 0 disk
├─sdb1 8:17 0 12.8T 0 part
├─sdb2 8:18 0 12.8T 0 part
├─sdb3 8:19 0 12.8T 0 part
├─sdb4 8:20 0 12.8T 0 part
└─mpathe (dm-3) 253:3 0 51T 0 mpath
├─mpathep1 (dm-4) 253:4 0 12.8T 0 part /SAN101
├─mpathep2 (dm-5) 253:5 0 12.8T 0 part /SAN102
├─mpathep3 (dm-6) 253:6 0 12.8T 0 part /SAN103
└─mpathep4 (dm-7) 253:7 0 12.8T 0 part /SAN104

sda and sdb are two views of the unit on the MD, sdc is the boot and root disk, one of the disks sde (mpathj) has a mounted file system, the remaining two do not. here is df:
Filesystem Type Size Used Avail Use% Mounted on
/dev/sdc2 ext4 31G 26G 4.0G 87% /
tmpfs tmpfs 16G 92K 16G 1% /dev/shm
/dev/sdc1 ext4 969M 127M 793M 14% /boot
/dev/sdc6 ext4 673G 242G 398G 38% /data01
/dev/mapper/mpathjp1 ext4 917G 196G 676G 23% /data02
/dev/sdc5 ext4 182G 169G 3.9G 98% /home
/dev/mapper/mpathep1 ext4 13T 11T 1005G 92% /SAN101
/dev/mapper/mpathep2 ext4 13T 5.0T 7.0T 42% /SAN102
/dev/mapper/mpathep3 ext4 13T 4.9T 7.1T 42% /SAN103
/dev/mapper/mpathep4 ext4 13T 8.2T 3.8T 69% /SAN104

So a few questions:

Is there any value in using multipath on the 4 internal drives; do they actually have multiple data paths?

Why does multipath not create a mpath device for the system disk sdc, there is no blacklist in the mulitpath.conf file. If I do a dry-run mulitpath -d command, it sets up mpathh on sdc, but apparently not on boot. Why not?
I should say that the system has not been rebooted since well before I took it over, it has been up for over 400 days.

the sdd and sdf disks have a single partition, but apparently no mpath device for the partition, how to I create one?

Thanks in advance

LEAVE A COMMENT