PHP and PHP53

Home » CentOS » PHP and PHP53
CentOS 3 Comments

We have someone requesting the use of WordPress 3.3.1. It requires PHP 5.2 minimum. Currently, our machine is running CentOS 5.7. What are the issues/concerns in upgrading from PHP 5.1 (the current PHP rpms) to PHP53?

Much thanks,

Max Pyziur

3 thoughts on - PHP and PHP53

  • I want to point out here that 5.2.17 is the last release of the 5.2
    branch and that it is NOT being updated for security by any
    more. There are already unpatched vulnerabilities. The 5.1.x (and
    php53) versions from EL5 will continue to get security updates until EL5
    goes EOL.

    If you have to use php-5.2.x then 5.2.17 is the one to use … however,
    it is not safe.

    As to the question of what is different … I think many 3rd party
    packages from repoforge and EPEL will not work well with php53 … but
    if you are staying inside the php53 universe, it should be OK.

  • We have been using php53 on all of our centos5 servers for severeal
    months, now. No major problem at all. Just set the timezone in /etc/php.ini.