– Problem Gcc With Yum

Home » CentOS » – Problem Gcc With Yum
CentOS 6 Comments

hi all,

today, I have this problem:

# yum install gcc Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile
* base: ftp.hosteurope.de
* epel: mirror.de.leaseweb.net
* extras: ftp.hosteurope.de
* updates: ftp.hosteurope.de Setting up Install Process Resolving Dependencies
–> Running transaction check
—> Package gcc.x86_64 0:4.4.7-3.el6 will be installed
–> Processing Dependency: libgomp = 4.4.7-3.el6 for package:
gcc-4.4.7-3.el6.x86_64
–> Processing Dependency: cpp = 4.4.7-3.el6 for package:
gcc-4.4.7-3.el6.x86_64
–> Processing Dependency: glibc-devel >= 2.2.90-12 for package:
gcc-4.4.7-3.el6.x86_64
–> Processing Dependency: cloog-ppl >= 0.15 for package:
gcc-4.4.7-3.el6.x86_64
–> Processing Dependency: libgomp.so.1()(64bit) for package:
gcc-4.4.7-3.el6.x86_64
–> Running transaction check
—> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed
–> Processing Dependency: libppl_c.so.2()(64bit) for package:
cloog-ppl-0.15.7-1.2.el6.x86_64
–> Processing Dependency: libppl.so.7()(64bit) for package:
cloog-ppl-0.15.7-1.2.el6.x86_64
—> Package cpp.x86_64 0:4.4.7-3.el6 will be installed
–> Processing Dependency: libmpfr.so.1()(64bit) for package:
cpp-4.4.7-3.el6.x86_64
—> Package glibc-devel.x86_64 0:2.12-1.107.el6_4.4 will be installed
–> Processing Dependency: glibc-headers = 2.12-1.107.el6_4.4 for package:
glibc-devel-2.12-1.107.el6_4.4.x86_64
–> Processing Dependency: glibc-headers for package:
glibc-devel-2.12-1.107.el6_4.4.x86_64
—> Package libgomp.x86_64 0:4.4.7-3.el6 will be installed
–> Running transaction check
—> Package glibc-headers.x86_64 0:2.12-1.107.el6_4.4 will be installed
–> Processing Dependency: kernel-headers >= 2.2.1 for package:
glibc-headers-2.12-1.107.el6_4.4.x86_64
–> Processing Dependency: kernel-headers for package:
glibc-headers-2.12-1.107.el6_4.4.x86_64
—> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed
—> Package ppl.x86_64 0:0.10.2-11.el6 will be installed
–> Finished Dependency Resolution Error: Package: glibc-headers-2.12-1.107.el6_4.4.x86_64 (updates)
Requires: kernel-headers >= 2.2.1
Error: Package: glibc-headers-2.12-1.107.el6_4.4.x86_64 (updates)
Requires: kernel-headers You could try using –skip-broken to work around the problem You could try running: rpm -Va –nofiles –nodigest

how can I fix?
thanks in advance

6 thoughts on - – Problem Gcc With Yum

  • Do you have the kernel-headers install? If not yum install kernel-headers

    This should resolve the issue because it’s required but missing.

  • As yum does the depsolving it should install the kernel-headers for you. It’s more likely that there is something in your yum conf that is excluding updates to kernel-headders. I’d check your config files.

    Tris

    *************************************************************
    This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify postmaster@bgfl.org

    The views expressed within this email are those of the individual, and not necessarily those of the organisation
    *************************************************************

  • this is the ls command in my /etc/yum.repos.d/ directory:

    CentOS-Base.repo CentOS-Debuginfo.repo CentOS-Media.repo CentOS-Vault.repo epel.repo epel-testing.repo

    which repository I have to enable?

    2013/10/10 Reindl Harald

  • sorry, I solved the problem I edited my yum.conf file and I deleted the string corresponding to the kernel*

    thanks for everything

    2013/10/10 Paolo De Michele

LEAVE A COMMENT