Samba Rpm Deps – With Yum Downgrade = Kind Of A Mayhem

Home » CentOS » Samba Rpm Deps – With Yum Downgrade = Kind Of A Mayhem
CentOS 4 Comments

hi guys, gals

do you see this:

~]$ yum downgrade samba Resolving Dependencies
–> Running transaction check
—> Package samba.x86_64 0:4.4.4-9.el7 will be a downgrade
–> Processing Dependency: samba-libs = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
–> Processing Dependency: samba-common-tools = 4.4.4-9.el7
for package: samba-4.4.4-9.el7.x86_64
–> Processing Dependency: samba-common-libs = 4.4.4-9.el7
for package: samba-4.4.4-9.el7.x86_64
–> Processing Dependency: samba-common = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
–> Processing Dependency: samba-client-libs = 4.4.4-9.el7
for package: samba-4.4.4-9.el7.x86_64
–> Processing Dependency: libwbclient = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
—> Package samba.x86_64 0:4.4.4-12.el7_3 will be erased
–> Running transaction check
—> Package libwbclient.i686 0:4.4.4-9.el7 will be installed
—> Package samba.x86_64 0:4.4.4-9.el7 will be a downgrade
–> Processing Dependency: samba-common-tools = 4.4.4-9.el7
for package: samba-4.4.4-9.el7.x86_64
–> Processing Dependency: samba-common-libs = 4.4.4-9.el7
for package: samba-4.4.4-9.el7.x86_64
–> Processing Dependency: samba-common = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
—> Package samba.x86_64 0:4.4.4-12.el7_3 will be erased
—> Package samba-client-libs.i686 0:4.4.4-9.el7 will be installed
–> Processing Dependency: samba-common = 4.4.4-9.el7 for package: samba-client-libs-4.4.4-9.el7.i686
–> Processing Dependency: libtevent.so.0(TEVENT_0.9.9) for package: samba-client-libs-4.4.4

..and process fails. chained are i686 arch? Is it only us(CentOS) or redhat’s bugzilla should be notified. Samba downgrade used to work I remember. bw. L.

4 thoughts on - Samba Rpm Deps – With Yum Downgrade = Kind Of A Mayhem

  • Most likely there are dependencies that aren’t available in your current repos that are preventing the downgrade. Perhaps its due to the recent point release to 7.1611?

    The packages installed with a ‘yum downgrade’ are unlikely to be supported, so this is probably not really something that CentOS
    supports.

  • but CentOS should, right?
    Being able to downgrade can save you a day or a few. I know, for it did save mine several times, eg. buggy samba new update and downgrade fixed it, etc. We absolutely should be able to downgrade every rpm, if this is just a matter of an opinion(I’d fail to see any other reasons to not do it) then my vote goes obviously to –
    CentOS/repos maintainers please make sure “yum downgrade”
    will always work.

    many thank, L

  • If you maintain your own private yum repositories, you can certainly downgrade to versions you provide yourself. But being able to downgrade to any arbitrary package using the CentOS repos would use up considerable storage resources. The repo maintainers aren’t psychic, so they’d have to keep EVERY SINGLE RPM. Every mirror would have to keep every RPM too.

    This is why I have a testing infrastructure to test updates.

  • no no, not every single rpm! Only one prior, one from which you are upgrading, would suffice. Don’t make it bigger than it actually is please. Other repos don’t have problem with it. AFAIR Scientific Linux had no problem with this, at least that was the case not that long ago, chances are they still to it.

LEAVE A COMMENT