Seeking Enlightenment (java And Dependencies)

Home » CentOS » Seeking Enlightenment (java And Dependencies)
CentOS 3 Comments

Ok, all you javaphiles, explain to me why, when I was looking to try to remove java-1.5.0-gcj and the -devel, it wanted to remove, as dependencies, things like tomcat6, ant, and gcc-java. Note that java-1.6.0-oipenjdk and -devel are installed….

mark

3 thoughts on - Seeking Enlightenment (java And Dependencies)

  • Gerry Reno wrote:

    Among a ton o’ other things, package: tomcat6.noarch 6.0.24-36.el6_2
    dependency: java
    provider: java-1.5.0-gcj.x86_64 1.5.0.0-29.1.el6
    provider: java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.41.1.10.4.el6
    provider: java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.50.1.11.5.el6_3
    provider: java-1.5.0-gcj.x86_64 1.5.0.0-29.1.el6
    provider: java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.56.1.11.8.el6_3
    provider: java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.57.1.11.9.el6_4
    provider: java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.42.1.10.4.el6_2
    provider: java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.43.1.10.6.el6_2

    You’d think there’d be options, but nooooo….

    mark

LEAVE A COMMENT