Trick To Compile Older Packages

Home » CentOS » Trick To Compile Older Packages
CentOS 1 Comment

I am trying to add a package (I know its older – but it should work)
gst-rtsp-server-0.10.8 to CentOS 7. The gstreamer 0.10 packages are included in C7 and they compile just fine.

When I extract and try to compile gst-rtsp-server 0.10.8 the ./configure goes fine. but the make results in errors:

make make all-recursive make[1]: Entering directory
`/home/silentm/LayeredSolutions/webkit-0.10/gst-rtsp-server-0.10.8.2′
Making all in gst make[2]: Entering directory
`/home/silentm/LayeredSolutions/webkit-0.10/gst-rtsp-server-0.10.8.2/gst’
Making all in rtsp-server make[3]: Entering directory
`/home/silentm/LayeredSolutions/webkit-0.10/gst-rtsp-server-0.10.8.2/gst/rtsp-server’
CC libgstrtspserver_0.10_la-rtsp-media.lo rtsp-media.c: In function ‘gst_rtsp_media_class_init’:
rtsp-media.c:143:3: error: ‘g_thread_create’ is deprecated (declared at
/usr/include/glib-2.0/glib/deprecated/gthread.h:104): Use ‘g_thread_new’
instead [-Werror

One thought on - Trick To Compile Older Packages

  • […]

    So, the root of this problem is building old code against a new glib2, without updating the code. But it _looks_ like this should just be a warning, and has been promoted to an error. Are you building with
    -Werror?

LEAVE A COMMENT