Yum Update Issues

Home » CentOS » Yum Update Issues
CentOS 2 Comments

Hello all,

When running yum update on a few of our servers, we get the following errors:

Running Transaction
Updating : openssl-1.0.1e-42.el6_7.4.x86_64

1/327
Updating : PostgreSQL-libs-8.4.20-5.el6_7.cloudlinux.x86_64

2/327
Updating : kernel-firmware-2.6.32-673.8.1.lve1.4.3.el6.noarch

3/327
Updating : kmod-lve-1.4-3.1.el6.x86_64

4/327
Installing :
kmod-lve-2.6.32-673.8.1.lve1.4.3.el6.x86_64-1.4-3.1.el6.x86_64

5/327
Installing : e1000e-3.3.3-2.el6.noarch

6/327
Installing :
kmod-e1000e-2.6.32-673.8.1.lve1.4.3.el6.x86_64.debug-3.3.3-2.el6.x86_64

7/327
Installing :
kmod-lve-2.6.32-673.8.1.lve1.4.3.el6.x86_64.debug-1.4-3.1.el6.x86_64

8/327
Installing : kernel-debug-2.6.32-673.8.1.lve1.4.3.el6.x86_64

9/327
Updating : liblve-1.4-1.3.el6.cloudlinux.x86_64

10/327
Updating : lve-1.4-1.3.el6.cloudlinux.x86_64

11/327
Installing :
kmod-e1000e-2.6.32-673.8.1.lve1.4.3.el6.x86_64-3.3.3-2.el6.x86_64

12/327
Installing : kernel-2.6.32-673.8.1.lve1.4.3.el6.x86_64

13/327

Traceback (most recent call last):
File “/usr/lib/python2.6/site-packages/yum/rpmtrans.py”, line 470, in callback
self._scriptStop(bytes, total, h);
File “/usr/lib/python2.6/site-packages/yum/rpmtrans.py”, line 636, in
_scriptStop
name, txmbr = self._getTxmbr(h)
File “/usr/lib/python2.6/site-packages/yum/rpmtrans.py”, line 331, in
_getTxmbr
assert len(txmbrs) == 1
AssertionError error: python callback > failed, aborting!

And if I try and run yum update again, I get the following:


–> Finished Dependency Resolution Error: cagefs conflicts with liblve-1.3-1.10.el6.cloudlinux.x86_64
You could try using –skip-broken to work around the problem
** Found 8 pre-existing rpmdb problem(s), ‘yum check’ output follows:
kernel-2.6.32-673.8.1.lve1.4.3.el6.x86_64 has missing requires of kmod-ixgbe-2.6.32-673.8.1.lve1.4.3.el6.x86_64
kernel-debug-2.6.32-673.8.1.lve1.4.3.el6.x86_64 has missing requires of kmod-ixgbe-2.6.32-673.8.1.lve1.4.3.el6.x86_64.debug kernel-firmware-2.6.32-673.8.1.lve1.4.3.el6.noarch is a duplicate with kernel-firmware-2.6.32-604.30.3.lve1.3.63.el6.noarch kmod-lve-1.4-3.1.el6.x86_64 is a duplicate with kmod-lve-1.3-11.1.el6.x86_64
liblve-1.4-1.3.el6.cloudlinux.x86_64 is a duplicate with liblve-1.3-1.10.el6.cloudlinux.x86_64
lve-1.4-1.3.el6.cloudlinux.x86_64 is a duplicate with lve-1.3-1.10.el6.cloudlinux.x86_64
openssl-1.0.1e-42.el6_7.4.x86_64 is a duplicate with openssl-1.0.1e-42.el6_7.2.x86_64
PostgreSQL-libs-8.4.20-5.el6_7.cloudlinux.x86_64 is a duplicate with PostgreSQL-libs-8.4.20-4.el6_7.cloudlinux.x86_64

When I check for duplicate packages:

*# package-cleanup –dupes*
Loaded plugins: fastestmirror, rhnplugin lve-1.4-1.3.el6.cloudlinux.x86_64
lve-1.3-1.10.el6.cloudlinux.x86_64
PostgreSQL-libs-8.4.20-5.el6_7.cloudlinux.x86_64
PostgreSQL-libs-8.4.20-4.el6_7.cloudlinux.x86_64
kmod-lve-1.4-3.1.el6.x86_64
kmod-lve-1.3-11.1.el6.x86_64
liblve-1.4-1.3.el6.cloudlinux.x86_64
liblve-1.3-1.10.el6.cloudlinux.x86_64
openssl-1.0.1e-42.el6_7.4.x86_64
openssl-1.0.1e-42.el6_7.2.x86_64

I then run package-cleanup –cleandupes and get the following:


Running Transaction
** Found 3 pre-existing rpmdb problem(s), ‘yum check’ output follows:
kernel-2.6.32-673.8.1.lve1.4.3.el6.x86_64 has missing requires of kmod-ixgbe-2.6.32-673.8.1.lve1.4.3.el6.x86_64
kernel-debug-2.6.32-673.8.1.lve1.4.3.el6.x86_64 has missing requires of kmod-ixgbe-2.6.32-673.8.1.lve1.4.3.el6.x86_64.debug kernel-firmware-2.6.32-673.8.1.lve1.4.3.el6.noarch is a duplicate with kernel-firmware-2.6.32-604.30.3.lve1.3.63.el6.noarch

So I then run:

yum install kmod-ixgbe-2.6.32-673.8.1.lve1.4.3.el6.x86_64

Only after cleaning the duplicates, and installing kmod-ixgbe, can I *then* run yum update -y, and it succeeds.

It’s extremely annoying because the above error is preventing cPanel updates from completing nightly (until I do the above), and I would love to know why this is suddenly happening on so many servers, for seemingly no reason.

Thanks in advance.

2 thoughts on - Yum Update Issues

LEAVE A COMMENT