6.4 X64 PyQt4 Package Not Compatible With Sip Package In Base Repo ?

Home » CentOS » 6.4 X64 PyQt4 Package Not Compatible With Sip Package In Base Repo ?
CentOS 1 Comment

Hi All,
i’m a happy 6.4 user, but got some problems running pyqt4 on it.
i installed all pyqt4 packages.
but when i run from PyQt4.QtCore import *, i got the following error message

>>> from PyQt4.QtCore import *
Traceback (most recent call last):
File ““, line 1, in
RuntimeError: the SIP module implements API v9.0 to v9.1 but the PyQt4.QtCore module requires API v6.0

and if i do yum remove sip, i saw the following message

Resolving Dependencies
–> Running transaction check
—> Package sip.x86_64 0:4.9.3-1.el6 will be erased
–> Processing Dependency: sip-api(6) >= 6.0 for package:
PyQt-3.18.1-12.el6.x86_64
–> Processing Dependency: sip-api(6) >= 6.0 for package:
PyQt4-4.6.2-9.el6.x86_64
–> Processing Dependency: sip = 4.9.3-1.el6 for package:
sip-devel-4.9.3-1.el6.x86_64
–> Running transaction check
—> Package PyQt.x86_64 0:3.18.1-12.el6 will be erased
—> Package PyQt4.x86_64 0:4.6.2-9.el6 will be erased
–> Processing Dependency: PyQt4 = 4.6.2-9.el6 for package:
PyQt4-devel-4.6.2-9.el6.x86_64
—> Package sip-devel.x86_64 0:4.9.3-1.el6 will be erased
–> Running transaction check
—> Package PyQt4-devel.x86_64 0:4.6.2-9.el6 will be erased
–> Finished Dependency Resolution

Dependencies Resolved

================================================================================================ Package Arch Version
Repository Size
================================================================================================Removing:
sip x86_64 4.9.3-1.el6
@base 473 k Removing for dependencies:
PyQt x86_64 3.18.1-12.el6
@epel 8.9 M
PyQt4 x86_64 4.6.2-9.el6
@base 13 M
PyQt4-devel x86_64 4.6.2-9.el6
@base 21 M
sip-devel x86_64 4.9.3-1.el6
@base 322 k

Transaction Summary
================================================================================================Remove 5 Package(s)

Installed size: 44 M
Is this ok [y/N]: n

does this mean , sip is too new , or pyqt4 is too old ?
why they are not working together even if they are on the same repo ?

thanks !

One thought on - 6.4 X64 PyQt4 Package Not Compatible With Sip Package In Base Repo ?

LEAVE A COMMENT