Can’t Update

Home » CentOS » Can’t Update
CentOS 4 Comments

Hi,

I can’t do update:

yum update Traceback (most recent call last):
File “/usr/bin/yum”, line 29, in
yummain.user_main(sys.argv[1:], exit_code=True)
File “/usr/share/yum-cli/yummain.py”, line 298, in user_main
errcode = main(args)
File “/usr/share/yum-cli/yummain.py”, line 110, in main base = cli.YumBaseCli()
File “/usr/share/yum-cli/cli.py”, line 72, in __init__
output.YumOutput.__init__(self)
File “/usr/share/yum-cli/output.py”, line 307, in __init__
self.reported_error_msgs = dict((k, False) for (k, v) in ERRORS_TO_KBASE_ARTICLES.iteritems())
NameError: global name ‘ERRORS_TO_KBASE_ARTICLES’ is not defined

Any suggestion ?

Thank’s​

4 thoughts on - Can’t Update

  • Hard to guess with this limited information. Usually this means either your yum or your python installation is broken.

    Are you using RPMs from outside of the CentOS or EPEL repos? Manually installed python versions? Manually installed python modules?

    best regards Ulf Volmer

  • Thank you for your response.

    # python -V

    Python 2.6.6

    # rpm -qa|grep python

    gnome-python2-bonobo-2.28.0-3.el6.x86_64

    gnome-python2-extras-2.25.3-20.el6.x86_64

    python-setuptools-0.6.10-3.el6.noarch

    python-unittest2-0.5.1-3.el6.noarch

    gnome-python2-gconf-2.28.0-3.el6.x86_64

    python-psycopg2-2.6-1.rhel6.x86_64

    python-feedparser-5.1.2-2.el6.noarch

    python-iwlib-0.1-1.2.el6.x86_64

    python-mock-0.8.0-2.el6.noarch

    python-imaging-1.1.6-19.el6.x86_64

    python-libs-2.6.6-64.el6.i686

    dbus-python-0.83.0-6.1.el6.x86_64

    python-docutils-0.6-1.el6.noarch

    python-dateutil-1.4.1-6.el6.noarch

    gnome-python2-desktop-2.28.0-5.el6.x86_64

    python-matplotlib-0.99.1.2-1.el6.x86_64

    gnome-python2-2.28.0-3.el6.x86_64

    gnome-python2-applet-2.28.0-5.el6.x86_64

    newt-python-0.52.11-3.el6.x86_64

    python-iniparse-0.3.1-2.1.el6.noarch

    python-gdata-2.0.11-1.el6.noarch

    python-chardet-2.2.1-1.el6.noarch

    python-markupsafe-0.9.2-4.el6.x86_64

    python-urlgrabber-3.9.1-11.el6.noarch

    python-suds-0.4.1-3.el6.noarch

    python-psutil-0.6.1-1.el6.x86_64

    libxslt-python-1.1.26-2.el6_3.1.x86_64

    python-jinja2-2.2.1-2.el6_5.x86_64

    gnome-python2-gnome-2.28.0-3.el6.x86_64

    python-passlib-1.5.3-1.el6.noarch

    hippo-canvas-python-0.3.0-6.el6.x86_64

    python-beaker-1.3.1-7.el6.noarch

    python-ethtool-0.6-5.el6.x86_64

    python-nose-0.10.4-3.1.el6.noarch

    python-lxml-2.2.3-1.1.el6.x86_64

    python-vobject-0.8.1c-5.el6.noarch

    python-yaml-3.09-3.el6.rf.x86_64

    python-libs-2.6.6-64.el6.x86_64

    python-mako-0.3.4-1.el6.noarch

    python-requests-2.6.0-3.el6.noarch

    python-devel-2.6.6-64.el6.x86_64

    rpm-python-4.8.0-55.el6.x86_64

    python-backports-ssl_match_hostname-3.4.0.2-4.el6.CentOS.noarch

    python-reportlab-2.3-3.el6.x86_64

    python-six-1.9.0-2.el6.noarch

    python-babel-0.9.4-5.1.el6.noarch

    gnome-python2-canvas-2.28.0-3.el6.x86_64

    python-vatnumber-1.0-1.el6.noarch

    gnome-python2-gnomevfs-2.28.0-3.el6.x86_64

    at-spi-python-1.28.1-2.el6.CentOS.x86_64

    python-simplejson-2.0.9-3.1.el6.x86_64

    python-werkzeug-0.8.3-2.el6.noarch

    python-tools-2.6.6-64.el6.x86_64

    python-urllib3-1.10.2-1.el6.noarch

    libxml2-python-2.7.6-21.el6_8.1.x86_64

    python-pycurl-7.19.0-9.el6.x86_64

    python-decorator-3.0.1-3.1.el6.noarch

    python-openid-2.2.5-7.el6.noarch

    python-2.6.6-64.el6.x86_64

    gnome-python2-libegg-2.25.3-20.el6.x86_64

    python-ldap-2.3.10-1.el6.x86_64

    libproxy-python-0.3.0-10.el6.x86_64

    python-backports-1.0-5.el6.x86_64

    gnome-python2-libwnck-2.28.0-5.el6.x86_64

    2017-11-16 16:11 GMT+00:00 Ulf Volmer :

  • Please do not top post.

    As far as i can see in your list, several RPMs are not from official sources. And your version numbers are quite old (from 2015 if i remember correctly).

    Maybe it will be easier to do a fresh installation instead of debugging your current one.

    best regards Ulf

LEAVE A COMMENT