CentOS 7 And Php 5.5

Home » CentOS » CentOS 7 And Php 5.5
CentOS 5 Comments

I am hoping that the wisdom of the group here can at least point me in the right direction.

I have a CentOS7 server that I need to upgrade php from 5.4 to 5.5. I’ve tried several tutorials to add the remi repository and enable php55, but I always end up at the same result:

Error: Package: php-5.5.38-1.el6.remi.x86_64 (remi-php55)
Requires: httpd-mmn = 20051115
Installed: httpd-2.4.6-40.el7.CentOS.4.x86_64 (@updates)
httpd-mmn = 20120211
httpd-mmn = 20120211×8664
httpd-mmn = 20120211-x86-64
Available: httpd-2.4.6-40.el7.CentOS.x86_64 (base)
httpd-mmn = 20120211×8664
httpd-mmn = 20120211-x86-64
httpd-mmn = 20120211
Available: httpd-2.4.6-40.el7.CentOS.1.x86_64 (updates)
httpd-mmn = 20120211×8664
httpd-mmn = 20120211-x86-64
httpd-mmn = 20120211
Error: Package: php-pecl-jsonc-1.3.10-1.el7.remi.5.4.x86_64 (remi)
Requires: php(api) = 20100412-64
Removing: php-common-5.4.45-11.el7.remi.x86_64 (@remi)
php(api) = 20100412-64
Updated By: php-common-5.5.38-1.el6.remi.x86_64 (remi-php55)
php(api) = 20121113-64
Available: php-common-5.4.16-36.el7_1.x86_64 (base)
php(api) = 20100412-64
Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates)
php(api) = 20100412-64
Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates)
php(api) = 20100412-64
Available: php-common-5.4.45-10.el7.remi.x86_64 (remi)
php(api) = 20100412-64
Available: php-common-5.5.37-1.el6.remi.x86_64 (remi-php55)
php(api) = 20121113-64
Error: Package: php-pecl-jsonc-1.3.10-1.el7.remi.5.4.x86_64 (remi)
Requires: php(zend-abi) = 20100525-64
Removing: php-common-5.4.45-11.el7.remi.x86_64 (@remi)
php(zend-abi) = 20100525-64
Updated By: php-common-5.5.38-1.el6.remi.x86_64 (remi-php55)
php(zend-abi) = 20121212-64
Available: php-common-5.4.16-36.el7_1.x86_64 (base)
php(zend-abi) = 20100525-64
Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates)
php(zend-abi) = 20100525-64
Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates)
php(zend-abi) = 20100525-64
Available: php-common-5.4.45-10.el7.remi.x86_64 (remi)
php(zend-abi) = 20100525-64
Available: php-common-5.5.37-1.el6.remi.x86_64 (remi-php55)
php(zend-abi) = 20121212-64
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

If I try –skip-broken, I get:

Packages skipped because of dependency problems:
gd-last-2.2.3-1.el7.remi.x86_64 from remi
libpng12-1.2.50-7.el7_2.x86_64 from updates
libzip-last-1.1.3-1.el7.remi.x86_64 from remi
php-5.5.38-1.el6.remi.x86_64 from remi-php55
php-cli-5.5.38-1.el6.remi.x86_64 from remi-php55
php-common-5.5.38-1.el6.remi.x86_64 from remi-php55
php-gd-5.5.38-1.el6.remi.x86_64 from remi-php55
php-mbstring-5.5.38-1.el6.remi.x86_64 from remi-php55
php-mcrypt-5.5.38-1.el6.remi.x86_64 from remi-php55
php-mysqlnd-5.5.38-1.el6.remi.x86_64 from remi-php55
php-pdo-5.5.38-1.el6.remi.x86_64 from remi-php55
php-pecl-jsonc-1.3.10-1.el7.remi.5.4.x86_64 from remi
php-pecl-zip-1.13.4-1.el6.remi.5.5.x86_64 from remi-php55
php-process-5.5.38-1.el6.remi.x86_64 from remi-php55
php-xml-5.5.38-1.el6.remi.x86_64 from remi-php55
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for php-common which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of php-common of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
–exclude php-common.otherarch … this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of php-common installed, but
yum can only see an upgrade for one of those architectures.
If you don’t want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of php-common installed already.
You can use “yum check” to get yum show these errors.

…you can also use –setopt=protected_multilib

5 thoughts on - CentOS 7 And Php 5.5

  • Looks like you are trying to install packages built for EL6 in EL7

    I’m fairly certain Remi has EL7 packages for PHP 7.

    If he doesn’t, I have php 5.6.x for EL7 – but it’s a radical update because I build against a new apache and LibreSSL which isn’t what a lot of people want.

    https://librelamp.com/

  • It is definitely supposed to be for EL7

    # Repository: http://rpms.remirepo.net/
    # Blog: http://blog.remirepo.net/
    # Forum: http://forum.remirepo.net/

    [remi]
    name=Remi’s RPM repository for Enterprise Linux 7 – $basearch
    #baseurl=http://rpms.remirepo.net/enterprise/7/remi/$basearch/
    mirrorlist=http://rpms.remirepo.net/enterprise/7/remi/mirror enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

    [remi-php55]
    name=Remi’s PHP 5.5 RPM repository for Enterprise Linux 7 – $basearch
    #baseurl=http://rpms.remirepo.net/enterprise/7/php55/$basearch/
    mirrorlist=http://rpms.remirepo.net/enterprise/7/php55/mirror
    # NOTICE: common dependencies are in “remi-safe”
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

    [remi-php56]
    name=Remi’s PHP 5.6 RPM repository for Enterprise Linux 7 – $basearch
    #baseurl=http://rpms.remirepo.net/enterprise/7/php56/$basearch/
    mirrorlist=http://rpms.remirepo.net/enterprise/7/php56/mirror
    # NOTICE: common dependencies are in “remi-safe”
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

  • Am 25.08.2016 um 15:47 schrieb Richard B. Pyne:

    [ … ]

    May I suggest you search help from the 3rd party repository? Remi is typically helpful with your own repository packages.

    Regards

    Alexander

LEAVE A COMMENT