RPM Install/upgrade Problem

Home » CentOS » RPM Install/upgrade Problem
CentOS 1 Comment

Hi,

For the last few updates I’m having a yum problem.

# yum update

gives the following error for e.g.

Running transaction
Updating : bash-4.2.45-5.el7_0.2.x86_64 1/10
Error unpacking rpm package bash-4.2.45-5.el7_0.2.x86_64
error: unpacking of archive failed on file /usr/bin/alias;5423b9bc:
cpio: open

The same problem happens if I try to use rpm for the update so it appears to be an rpm problem rather than a yum one.

I’ve rebuilt the rpm databases successfully but tthe problem persists.

Regards,

Tony

One thought on - RPM Install/upgrade Problem

  • It may be that you have a bad bash RPM from somewhere. I believe that the cpio command works directly on the package so you could try with cpio on the command line to see if it will open the RPM. I suspect that it won’t be able to.

    Cheers,

    Cliff

LEAVE A COMMENT