Skype Not Starting Anymore, Prelink Issue?

Home » CentOS » Skype Not Starting Anymore, Prelink Issue?
CentOS 7 Comments

Hello there!

I was running skype 4.1.0.20 on my 64-bit laptop for weeks (installed in /opt, from an official skype binary archive, plus few 32-bit stuff to get it working), when suddenly it stopped working, no way to start it:

$ skype Fatal: QWidget: Must construct a QApplication before a QPaintDevice Aborted

A quick search on the Internet brought some possible solution, basically configuring prelink to skip skype binary, uninstall skype, reinstall it. I was doubtful about uninstall/reinstall step since I
didn’t install it using a RPM but from a binary archive. Anyway I did it, restarted even the computer. No way to start skype.

For now I’m stuck w/ an former staticQT 4.0.0.8 version of skype, which has no support for MSN accounts. Please note that I’m not using skype+msn because I want, but because I need to (@work).

Did anybody ever solve this issue or has a clue about how to do it?

Regards,

7 thoughts on - Skype Not Starting Anymore, Prelink Issue?

  • Hello Yves,

    This point has already been answered on this mailing list (and elsewhere). A bit of search in the archives and elsewhere would quickly bring you this:
    http://wiki.CentOS.org/HowTos/Skype

    Because Skype is 32-bit, the idea is to install it from the official binary archive, and use yum to install few 32-bit libraries (yes, this means that some libraries will be in 32-bit and 64-bit on your system, not a problem). Sound and video work like a charm, skype+msn support.

    Regards,

  • I’m very familiar with that document. :-) And many users, including myself, couldn’t get Skype 4.1 to work on CentOS 64 bits using those instructions.

    If Skype 4.1 did work on your 64-bit system, I’m very interested in knowing the details; you can contact me directly if you wish.

    (Skype 4.0 does work; in your initial post, you said that 4.1.0.20 used to work on your system, but no longer does.)

    Yves

  • Hello Yves,

    Yep, well I think I also followed a blog post somewhere on the internet, which was more detailed. Anyway nothing was different from using ldd to know what 32-bit deps the skype binary has and install the appropriate lib. I didn’t do any magic or setup in the system config files. That simply worked by installing 32-bit stuff.

    Regards,

  • Hello Yves,

    Got skype 4.1 to work again here, just unpacked the binary archive over the existing files, don’t know what went broken or how..

    FYI, I’ve made a list of the packages showing from a `ldd skype`, this may indicate what you need to install, at least (here: CentOS6.3 up-to-date, epel repo enabled):

    alsa-lib-1.0.22-3.el6.i686
    dbus-libs-1.2.24-7.el6_3.i686
    expat-2.0.1-11.el6_2.i686
    flac-1.2.1-6.1.el6.i686
    fontconfig-2.8.0-3.el6.i686
    freetype-2.3.11-14.el6_3.1.i686
    glib2-2.22.5-7.el6.i686
    glibc-2.12-1.80.el6_3.7.i686
    keyutils-libs-1.4-4.el6.i686
    krb5-libs-1.9-33.el6_3.3.i686
    libasyncns-0.8-1.1.el6.i686
    libcom_err-1.41.12-12.el6.i686
    libgcc-4.4.6-4.el6.i686
    libICE-1.0.6-1.el6.i686
    libogg-1.1.4-2.1.el6.i686
    libpng-1.2.49-1.el6_2.i686
    libselinux-2.0.94-5.3.el6.i686
    libSM-1.1.0-7.1.el6.i686
    libsndfile-1.0.20-5.el6.i686
    libstdc++-4.4.6-4.el6.i686
    libuuid-2.17.2-12.7.el6_3.i686
    libvorbis-1.2.3-4.el6_2.1.i686
    libX11-1.3-2.el6.i686
    libXau-1.0.5-1.el6.i686
    libxcb-1.5-1.el6.i686
    libXcursor-1.1.10-2.el6.i686
    libXext-1.1-3.el6.i686
    libXfixes-4.0.4-1.el6.i686
    libXi-1.3-3.el6.i686
    libXinerama-1.1-1.el6.i686
    libXrandr-1.3.0-4.el6.i686
    libXrender-0.9.5-1.el6.i686
    libXScrnSaver-1.2.0-1.el6.i686
    libXtst-1.0.99.2-3.el6.i686
    libXv-1.0.5-1.el6.i686
    openssl-1.0.0-25.el6_3.1.i686
    pulseaudio-libs-0.9.21-14.el6_3.i686
    pulseaudio-libs-glib2-0.9.21-14.el6_3.i686
    sqlite-3.6.20-1.el6.i686
    tcp_wrappers-libs-7.6-57.el6.i686
    zlib-1.2.3-27.el6.i686

    Of course there may have indirect dependencies, but yum would tell you that in time.

    Important: I also have a full Qt 4.7 32-bit in /usr/lib/qt47, on which my installed skype version depends on:
    libphonon.so.4
    libQtCore.so.4
    libQtDBus.so.4
    libQtGui.so.4
    libQtNetwork.so.4
    libQtWebKit.so.4
    libQtXml.so.4

    I was not sure if I got this specific Qt version installed for GuitarPro6 (commercial) or skype, but my LD_LIBRARY_PATH points to that dir and it can’t using the Qt 4.6 or 4.8 versions installed locally (install from one of those repositories: base, epel, rpmforge, puias, atrpms).

    For this Qt47, I downloaded the following RPMs:
    phonon-backend-gstreamer-4.7.2-1_18.el6.i686.rpm qt47-4.7.2-1_18.el6.i686.rpm qt47-config-4.7.2-1_18.el6.i686.rpm qt47-webkit-4.7.2-1_18.el6.i686.rpm qt47-x11-4.7.2-1_18.el6.i686.rpm

    And installed *manually* their contents to /usr/lib/qt47.

    This also requires tweaking a bit in /usr/lib/qt47/bin and /usr/bin
    (it’s safe towards system Qt versions, it’s just about fixing the missing q* qt47 apps and making correct symlinks isolated in /usr/lib/qt47/bin):
    See my /usr/lib/qt47/bin contents:
    qdbus -> ../../../bin/qdbus-qt47
    qdbusviewer -> ../../../bin/qdbusviewer-qt47
    qmlviewer -> ../../../bin/qmlviewer-qt47
    qtconfig -> ../../../bin/qtconfig-qt47
    qtconfig-qt47 -> ../../../bin/qtconfig-qt47

    Let me know if you succeed or still miss something!

    Regards,

  • Yves Bellefeuille wrote:

    I have posted it months ago here:

    http://community.skype.com/t5/Linux/Skype-for-Redhat-Enterprise-6/td-p/1210686

    Actually, I also posted to the c6 fora back then and suggested to document it more precisely in the wiki.

    That posting was immediately closed without further ado. Someone even followed me to the skype fora, only to state that I’m just talking bullshit and that http://wiki.CentOS.org/HowTos/Skype has all you need to know.

    And of course yes: Skype-4.1 is running nicely here on x86_64 for all these months. And it doesn’t require anything special — and certainly not breaking your installation with some weird Qt-4.7.

LEAVE A COMMENT