Yum Upgrade Of An Older 6.1

Home » CentOS » Yum Upgrade Of An Older 6.1
CentOS 1 Comment

i fired up a vm i haven’t used in ages, it was CentOS 6.1, so I ran yum update -y, and it bombed on package conflicts with matahari and qpid-something… I had no need for matahari (heck, I don’t even know what it is), so I removed matahari-\* and the yum update succeeded, but shouldn’t yum update be able to update ANY CentOS 6 to latest ? this system has NO extra repos, just CentOS-Base etc.

One thought on - Yum Upgrade Of An Older 6.1

  • http://wiki.CentOS.org/Manuals/ReleaseNotes/CentOS6.3 (Section 4. Major Changes)

    Matahari is now obsoleted, but in 6.1, had a dependency on qpid-cpp-server and qpid-cpp-client which wanted updates. A quick Google shows many others seeing this problem. I think if you run yum with the –obsoletes flag you may get more information. IMHO you need a human to decide when/if to remove the obsoleted packages and proceed with the update.

LEAVE A COMMENT